lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 09 Sep 2016 11:55:44 -0700
From:   Joe Perches <joe@...ches.com>
To:     Borislav Petkov <bp@...en8.de>,
        "Moore, Robert" <robert.moore@...el.com>
Cc:     LKML <linux-kernel@...r.kernel.org>,
        "Zheng, Lv" <lv.zheng@...el.com>,
        "Wysocki, Rafael J" <rafael.j.wysocki@...el.com>,
        Len Brown <lenb@...nel.org>,
        "linux-acpi@...r.kernel.org" <linux-acpi@...r.kernel.org>,
        "devel@...ica.org" <devel@...ica.org>
Subject: Re: [PATCH] ACPICA / Interpreter: Remove redundant newline

On Fri, 2016-09-09 at 20:40 +0200, Borislav Petkov wrote:
> On Fri, Sep 09, 2016 at 06:26:17PM +0000, Moore, Robert wrote:
> > Is this a big deal?
> > We do this on purpose for AcpiExec, to make the screen output more readable.
[]
> What do you mean "big deal"? All other ACPI_INFO calls don't have a "\n"
> at the end except this one. How does one "\n" make some output more
> readable?

Blank lines in logging/dmesg generally don't add value.

I would prefer if the unnecessary double parentheses also
were removed in these macro uses and ##__VA_ARGS__ was
used instead.

/*
 * Error reporting. Callers module and line number are inserted by AE_INFO,
 * the plist contains a set of parens to allow variable-length lists.
 * These macros are used for both the debug and non-debug versions of the code.
 */
#define ACPI_INFO(plist)                acpi_info plist
#define ACPI_WARNING(plist)             acpi_warning plist
#define ACPI_EXCEPTION(plist)           acpi_exception plist
#define ACPI_ERROR(plist)               acpi_error plist
#define ACPI_BIOS_WARNING(plist)        acpi_bios_warning plist
#define ACPI_BIOS_ERROR(plist)          acpi_bios_error plist

It would also be good if format/argument verification
was done here and in the non-debug macro variants.

#define ACPI_INFO(plist)
#define ACPI_WARNING(plist)
#define ACPI_EXCEPTION(plist)
#define ACPI_ERROR(plist)
#define ACPI_BIOS_WARNING(plist)
#define ACPI_BIOS_ERROR(plist)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ