lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 8 Nov 2016 19:46:32 +1100
From:   Alexey Kardashevskiy <aik@...abs.ru>
To:     Kirti Wankhede <kwankhede@...dia.com>, alex.williamson@...hat.com,
        pbonzini@...hat.com, kraxel@...hat.com, cjia@...dia.com
Cc:     qemu-devel@...gnu.org, kvm@...r.kernel.org, kevin.tian@...el.com,
        jike.song@...el.com, bjsdjshi@...ux.vnet.ibm.com,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH v11 15/22] vfio: Introduce
 vfio_set_irqs_validate_and_prepare()

On 05/11/16 08:10, Kirti Wankhede wrote:
> Vendor driver using mediated device framework would use same mechnism to
> validate and prepare IRQs. Introducing this function to reduce code
> replication in multiple drivers.
> 
> Signed-off-by: Kirti Wankhede <kwankhede@...dia.com>
> Signed-off-by: Neo Jia <cjia@...dia.com>
> Change-Id: Ie201f269dda0713ca18a07dc4852500bd8b48309
> ---
>  drivers/vfio/vfio.c  | 48 ++++++++++++++++++++++++++++++++++++++++++++++++
>  include/linux/vfio.h |  4 ++++
>  2 files changed, 52 insertions(+)
> 
> diff --git a/drivers/vfio/vfio.c b/drivers/vfio/vfio.c
> index 9a03be0942a1..ed2361e4b904 100644
> --- a/drivers/vfio/vfio.c
> +++ b/drivers/vfio/vfio.c
> @@ -1858,6 +1858,54 @@ int vfio_info_add_capability(struct vfio_info_cap *caps, int cap_type_id,
>  }
>  EXPORT_SYMBOL(vfio_info_add_capability);
>  
> +int vfio_set_irqs_validate_and_prepare(struct vfio_irq_set *hdr, int num_irqs,
> +				       int max_irq_type, size_t *data_size)
> +{
> +	unsigned long minsz;
> +	size_t size;
> +
> +	minsz = offsetofend(struct vfio_irq_set, count);
> +
> +	if ((hdr->argsz < minsz) || (hdr->index >= max_irq_type) ||
> +	    (hdr->count >= (U32_MAX - hdr->start)) ||
> +	    (hdr->flags & ~(VFIO_IRQ_SET_DATA_TYPE_MASK |
> +				VFIO_IRQ_SET_ACTION_TYPE_MASK)))
> +		return -EINVAL;
> +
> +	if (data_size)

Pointless check, the callers will pass non null pointer with value
initialized to 0 anyway.


> +		*data_size = 0;
> +
> +	if (hdr->start >= num_irqs || hdr->start + hdr->count > num_irqs)
> +		return -EINVAL;
> +
> +	switch (hdr->flags & VFIO_IRQ_SET_DATA_TYPE_MASK) {
> +	case VFIO_IRQ_SET_DATA_NONE:
> +		size = 0;
> +		break;
> +	case VFIO_IRQ_SET_DATA_BOOL:
> +		size = sizeof(uint8_t);
> +		break;
> +	case VFIO_IRQ_SET_DATA_EVENTFD:
> +		size = sizeof(int32_t);
> +		break;
> +	default:
> +		return -EINVAL;
> +	}
> +
> +	if (size) {

The whole branch would even work for size == 0.

> +		if (hdr->argsz - minsz < hdr->count * size)
> +			return -EINVAL;
> +
> +		if (!data_size)
> +			return -EINVAL;

Redundant check as well.

> +
> +		*data_size = hdr->count * size;
> +	}
> +
> +	return 0;
> +}

It does not really prepare anything as the name suggests. It looks like
this is 2 different helpers actually:

int vfio_set_irqs_validate()
and
size_t vfio_set_irqs_hdr_to_data_size()


And it would make it easier to review/bisect if 16/22 and 17/22 were merged
into this one as this patch alone adds new code which it does not use and
all 3 patches are fairly small.


> +EXPORT_SYMBOL(vfio_set_irqs_validate_and_prepare);

Everything you export in this patchset is EXPORT_SYMBOL() while the
existing code uses EXPORT_SYMBOL_GPL(), is this for a reason?


> +
>  /*
>   * Pin a set of guest PFNs and return their associated host PFNs for local
>   * domain only.
> diff --git a/include/linux/vfio.h b/include/linux/vfio.h
> index cf90393a11e2..87c9afecd822 100644
> --- a/include/linux/vfio.h
> +++ b/include/linux/vfio.h
> @@ -116,6 +116,10 @@ extern void vfio_info_cap_shift(struct vfio_info_cap *caps, size_t offset);
>  extern int vfio_info_add_capability(struct vfio_info_cap *caps,
>  				    int cap_type_id, void *cap_type);
>  
> +extern int vfio_set_irqs_validate_and_prepare(struct vfio_irq_set *hdr,
> +					      int num_irqs, int max_irq_type,
> +					      size_t *data_size);
> +
>  struct pci_dev;
>  #ifdef CONFIG_EEH
>  extern void vfio_spapr_pci_eeh_open(struct pci_dev *pdev);
> 


-- 
Alexey

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ