lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 9 Feb 2017 12:12:27 +0100
From:   Geert Uytterhoeven <geert@...ux-m68k.org>
To:     SF Markus Elfring <elfring@...rs.sourceforge.net>
Cc:     linux-m68k <linux-m68k@...ts.linux-m68k.org>,
        LKML <linux-kernel@...r.kernel.org>,
        "kernel-janitors@...r.kernel.org" <kernel-janitors@...r.kernel.org>
Subject: Re: [PATCH 3/3] m68k: Add some spaces for better code readability in sys_cacheflush()

Hi Markus,

On Wed, Jan 18, 2017 at 5:50 PM, SF Markus Elfring
<elfring@...rs.sourceforge.net> wrote:
> From: Markus Elfring <elfring@...rs.sourceforge.net>
> Date: Wed, 18 Jan 2017 17:34:29 +0100
>
> * Use space characters at some source code places according to
>   the Linux coding style convention.
>
> * Adjust indentation a bit.
>
> Signed-off-by: Markus Elfring <elfring@...rs.sourceforge.net>
> ---
>  arch/m68k/kernel/sys_m68k.c | 9 ++++-----
>  1 file changed, 4 insertions(+), 5 deletions(-)
>
> diff --git a/arch/m68k/kernel/sys_m68k.c b/arch/m68k/kernel/sys_m68k.c
> index 9870d00d2215..5b351f7a6c11 100644
> --- a/arch/m68k/kernel/sys_m68k.c
> +++ b/arch/m68k/kernel/sys_m68k.c
> @@ -436,11 +436,10 @@ sys_cacheflush (unsigned long addr, int scope, int cache, unsigned long len)
>              * 040 or 060: don't blindly trust 'scope', someone could
>              * try to flush a few megs of memory.
>              */
> -
> -           if (len>=3*PAGE_SIZE && scope<FLUSH_SCOPE_PAGE)
> -               scope=FLUSH_SCOPE_PAGE;
> -           if (len>=10*PAGE_SIZE && scope<FLUSH_SCOPE_ALL)
> -               scope=FLUSH_SCOPE_ALL;
> +               if (len >= 3 * PAGE_SIZE && scope < FLUSH_SCOPE_PAGE)
> +                       scope = FLUSH_SCOPE_PAGE;
> +               if (len >= 10 * PAGE_SIZE && scope < FLUSH_SCOPE_ALL)
> +                       scope = FLUSH_SCOPE_ALL;
>             if (CPU_IS_040) {
>                 ret = cache_flush_040 (addr, scope, cache, len);
>             } else if (CPU_IS_060) {

What prevented you from correcting the indentation of the comments before,
and the statements after?
Now the lines in the else branch are no longer aligned at all!

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@...ux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ