lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 10 Mar 2017 01:16:53 +0100
From:   Andrew Lunn <andrew@...n.ch>
To:     Vivien Didelot <vivien.didelot@...oirfairelinux.com>
Cc:     netdev@...r.kernel.org, linux-kernel@...r.kernel.org,
        kernel@...oirfairelinux.com,
        "David S. Miller" <davem@...emloft.net>,
        Florian Fainelli <f.fainelli@...il.com>
Subject: Re: [PATCH net-next 08/14] net: dsa: mv88e6xxx: rename new FID helper

On Thu, Mar 09, 2017 at 06:33:18PM -0500, Vivien Didelot wrote:
> Rename the _mv88e6xxx_fid_new helper to mv88e6xxx_atu_new to get rid of
> the old underscore prefix naming convention and be consistent with the
> rest of the chip-wide ATU API.

Hi Vivien

This is the sort of patch i like. Obviously correct, reviewed in a few
seconds.

Reviewed-by: Andrew Lunn <andrew@...n.ch>

    Andrew


> 
> Signed-off-by: Vivien Didelot <vivien.didelot@...oirfairelinux.com>
> ---
>  drivers/net/dsa/mv88e6xxx/chip.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/net/dsa/mv88e6xxx/chip.c b/drivers/net/dsa/mv88e6xxx/chip.c
> index 72304ca6e5f0..e45c2f3ed654 100644
> --- a/drivers/net/dsa/mv88e6xxx/chip.c
> +++ b/drivers/net/dsa/mv88e6xxx/chip.c
> @@ -1558,7 +1558,7 @@ static int _mv88e6xxx_stu_loadpurge(struct mv88e6xxx_chip *chip,
>  	return _mv88e6xxx_vtu_cmd(chip, GLOBAL_VTU_OP_STU_LOAD_PURGE);
>  }
>  
> -static int _mv88e6xxx_fid_new(struct mv88e6xxx_chip *chip, u16 *fid)
> +static int mv88e6xxx_atu_new(struct mv88e6xxx_chip *chip, u16 *fid)
>  {
>  	DECLARE_BITMAP(fid_bitmap, MV88E6XXX_N_FID);
>  	struct mv88e6xxx_vtu_entry vlan;
> @@ -1612,7 +1612,7 @@ static int _mv88e6xxx_vtu_new(struct mv88e6xxx_chip *chip, u16 vid,
>  	};
>  	int i, err;
>  
> -	err = _mv88e6xxx_fid_new(chip, &vlan.fid);
> +	err = mv88e6xxx_atu_new(chip, &vlan.fid);
>  	if (err)
>  		return err;
>  
> -- 
> 2.12.0
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ