lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sat, 25 Mar 2017 16:36:21 -0700
From:   "Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>
To:     Nicholas Mc Guire <der.herr@...r.at>
Cc:     Josh Triplett <josh@...htriplett.org>,
        Steven Rostedt <rostedt@...dmis.org>,
        Mathieu Desnoyers <mathieu.desnoyers@...icios.com>,
        Lai Jiangshan <jiangshanlai@...il.com>,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/2] rcu: use bool value directly

On Sat, Mar 25, 2017 at 08:46:01PM +0100, Nicholas Mc Guire wrote:
> beenonline is declared bool so no need for an explicit comparison
> 
> Signed-off-by: Nicholas Mc Guire <der.herr@...r.at>

Queued both for review and testing, thank you!

						Thanx, Paul

> ---
> 
> Found by coccinelle: boolinit.cocci complained about
> ./kernel/rcu/tree.c:2986:14-29: WARNING: Comparison of bool to 0/1
> 
> If the comparison was intended for readability I guess it should be
> against "false" not 0 - but it seems common to just use bool values
> directly.
> 
> Patch was compile-tested with: x86_64_defconfig (implies CONFIG_TREE_RCU=y)
> (with some sparse warnings)
> 
> Patch is against 4.11-rc3 (localversion-next is next-20170324)
> 
>  kernel/rcu/tree.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/kernel/rcu/tree.c b/kernel/rcu/tree.c
> index 712ddce..ab9fbec 100644
> --- a/kernel/rcu/tree.c
> +++ b/kernel/rcu/tree.c
> @@ -2983,7 +2983,7 @@ __rcu_process_callbacks(struct rcu_state *rsp)
>  	bool needwake;
>  	struct rcu_data *rdp = raw_cpu_ptr(rsp->rda);
> 
> -	WARN_ON_ONCE(rdp->beenonline == 0);
> +	WARN_ON_ONCE(!rdp->beenonline);
> 
>  	/* Update RCU state based on any recent quiescent states. */
>  	rcu_check_quiescent_state(rsp, rdp);
> -- 
> 2.1.4
> 

Powered by blists - more mailing lists