lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 29 Aug 2017 16:34:53 +0900
From:   Andi Shyti <andi.shyti@...sung.com>
To:     Chen Zhong <chen.zhong@...iatek.com>
Cc:     Dmitry Torokhov <dmitry.torokhov@...il.com>,
        Rob Herring <robh+dt@...nel.org>,
        Mark Rutland <mark.rutland@....com>,
        Matthias Brugger <matthias.bgg@...il.com>,
        Lee Jones <lee.jones@...aro.org>,
        Eddie Huang <eddie.huang@...iatek.com>,
        Alessandro Zummo <a.zummo@...ertech.it>,
        Alexandre Belloni <alexandre.belloni@...e-electrons.com>,
        Javier Martinez Canillas <javier@....samsung.com>,
        Linus Walleij <linus.walleij@...aro.org>,
        Jaechul Lee <jcsing.lee@...sung.com>,
        linux-input@...r.kernel.org, devicetree@...r.kernel.org,
        linux-arm-kernel@...ts.infradead.org,
        linux-mediatek@...ts.infradead.org, linux-kernel@...r.kernel.org,
        linux-rtc@...r.kernel.org
Subject: Re: [PATCH v3 4/5] input: Add MediaTek PMIC keys support

Hi Chen,

what I would ask you is to be consistent with the naming, if your
driver is called mtk-pmic, then all your functions and global
variables should be named accordingly as mtk_pmic or MTK_PMIC.
Please check in between the lines for real examples:

> +#define PWRKEY_RST_EN_MASK	0x1
> +#define PWRKEY_RST_EN_SHIFT	6
> +#define HOMEKEY_RST_EN_MASK	0x1
> +#define HOMEKEY_RST_EN_SHIFT	5
> +#define RST_DU_MASK		0x3
> +#define RST_DU_SHIFT		8
> +
> +#define PMIC_PWRKEY_INDEX	0
> +#define PMIC_HOMEKEY_INDEX	1
> +#define PMIC_MAX_KEY_COUNT	2

#define MTK_PMIC_*

> +struct pmic_keys_regs {

struct mtk_pmic_keys_regs

> +	u32 deb_reg;
> +	u32 deb_mask;
> +	u32 intsel_reg;
> +	u32 intsel_mask;
> +};
> +
> +#define PMIC_KEYS_REGS(_deb_reg, _deb_mask, _intsel_reg, _intsel_mask)	\

MTK_PMIC_KEYS_REGS

> +{									\
> +	.deb_reg		= _deb_reg,				\
> +	.deb_mask		= _deb_mask,				\
> +	.intsel_reg		= _intsel_reg,				\
> +	.intsel_mask		= _intsel_mask,				\
> +}
> +
> +struct pmic_regs {

mtk_pmic_regs

and so on... you got the point.

Andi

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ