lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 29 Dec 2017 01:36:48 +0100
From:   Jessica Yu <jeyu@...nel.org>
To:     Steven Rostedt <rostedt@...dmis.org>
Cc:     Namit Gupta <gupta.namit@...sung.com>, mingo@...hat.com,
        linux-kernel@...r.kernel.org, pankaj.m@...sung.com,
        a.sahrawat@...sung.com, rusty@...tcorp.com.au
Subject: Re: ftrace/module: Move ftrace_release_mod to ddebug_cleanup label

+++ Steven Rostedt [28/12/17 11:32 -0500]:
>
>Jessica,
>
>Can you take this patch. You can add:
>
>Reviewed-by: Steven Rostedt (VMware) <rostedt@...dmis.org>

Sure, thanks Steven.

Namit, your patch does not apply cleanly to modules-next nor
linux-next. It looks like you based your patch on an old tree?
(e.g., we got rid of the module_core and core_size fields a few years
ago...) Could you please rebase your patch on linux-next and resend? 

Thanks,

Jessica

>On Tue, 12 Dec 2017 17:24:32 +0530
>Namit Gupta <gupta.namit@...sung.com> wrote:
>
>> ftrace_module_init happen after dynamic_debug_setup, it is desired that
>> cleanup should be called after this label however in current implementation
>> it is called in free module label,ie:even though ftrace in not initialized,
>> from so many fail case ftrace_release_mod() will be called and unnecessary
>> traverse the whole list.
>> In below patch we moved ftrace_release_mod() from free_module label to
>> ddebug_cleanup label. that is the best possible location, other solution
>> is to make new label to ftrace_release_mod() but since ftrace_module_init()
>> is not return with minimum changes it should be in ddebug_cleanup label.
>>
>>
>> Signed-off-by: Namit Gupta <gupta.namit@...sung.com>
>>
>> ---
>>  kernel/module.c | 7 +------
>>  1 file changed, 1 insertion(+), 6 deletions(-)
>>
>> diff --git a/kernel/module.c b/kernel/module.c
>> index 0d1cb8d..4be966a 100644
>> --- a/kernel/module.c
>> +++ b/kernel/module.c
>> @@ -3523,6 +3523,7 @@ static int load_module(struct load_info *info, const char __user *uargs,
>>  	unset_module_core_ro_nx(mod);
>>
>>   ddebug_cleanup:
>> +	ftrace_release_mod(mod);
>>  	dynamic_debug_remove(info->debug);
>>  	synchronize_sched();
>>  	kfree(mod->args);
>> @@ -3541,12 +3542,6 @@ static int load_module(struct load_info *info, const char __user *uargs,
>>  	synchronize_rcu();
>>  	mutex_unlock(&module_mutex);
>>   free_module:
>> -	/*
>> -	 * Ftrace needs to clean up what it initialized.
>> -	 * This does nothing if ftrace_module_init() wasn't called,
>> -	 * but it must be called outside of module_mutex.
>> -	 */
>> -	ftrace_release_mod(mod);
>>  	/* Free lock-classes; relies on the preceding sync_rcu() */
>>  	lockdep_free_key_range(mod->module_core, mod->core_size);
>>
>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ