lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 15 Jan 2018 22:22:32 +0200
From:   Amir Goldstein <amir73il@...il.com>
To:     Hans de Goede <hdegoede@...hat.com>
Cc:     Arnd Bergmann <arnd@...db.de>,
        Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
        Michael Thayer <michael.thayer@...cle.com>,
        Alexander Viro <viro@...iv.linux.org.uk>,
        Larry Finger <Larry.Finger@...inger.net>,
        Christoph Hellwig <hch@...radead.org>,
        linux-kernel <linux-kernel@...r.kernel.org>,
        linux-fsdevel <linux-fsdevel@...r.kernel.org>
Subject: Re: [PATCH v2] fs: Add VirtualBox guest shared folder (vboxsf) support

On Mon, Jan 15, 2018 at 9:41 PM, Hans de Goede <hdegoede@...hat.com> wrote:
> Hi,
>
>
> On 15-01-18 20:32, Amir Goldstein wrote:
>>
>> On Mon, Jan 15, 2018 at 7:51 PM, Hans de Goede <hdegoede@...hat.com>
>> wrote:
>>>
>>> VirtualBox hosts can share folders with guests, this commit adds a
>>> VFS driver implementing the Linux-guest side of this, allowing folders
>>> exported by the host to be mounted under Linux.
>>>
>>> This driver depends on the guest <-> host IPC functions exported by
>>> the vboxguest driver.
>>>
>>> Signed-off-by: Hans de Goede <hdegoede@...hat.com>
>>> ---
>>>   fs/Kconfig                     |   1 +
>>>   fs/Makefile                    |   1 +
>>>   fs/vboxsf/Kconfig              |   9 +
>>>   fs/vboxsf/Makefile             |   3 +
>>>   fs/vboxsf/dir.c                | 648 +++++++++++++++++++++++++++++
>>>   fs/vboxsf/file.c               | 416 +++++++++++++++++++
>>>   fs/vboxsf/shfl_hostintf.h      | 919
>>> +++++++++++++++++++++++++++++++++++++++++
>>>   fs/vboxsf/super.c              | 430 +++++++++++++++++++
>>>   fs/vboxsf/utils.c              | 589 ++++++++++++++++++++++++++
>>>   fs/vboxsf/vboxsf_wrappers.c    | 365 ++++++++++++++++
>>>   fs/vboxsf/vboxsf_wrappers.h    |  46 +++
>>>   fs/vboxsf/vfsmod.h             | 104 +++++
>>>   include/uapi/linux/vbsfmount.h |  62 +++
>>>   13 files changed, 3593 insertions(+)
>>>   create mode 100644 fs/vboxsf/Kconfig
>>>   create mode 100644 fs/vboxsf/Makefile
>>>   create mode 100644 fs/vboxsf/dir.c
>>>   create mode 100644 fs/vboxsf/file.c
>>>   create mode 100644 fs/vboxsf/shfl_hostintf.h
>>>   create mode 100644 fs/vboxsf/super.c
>>>   create mode 100644 fs/vboxsf/utils.c
>>>   create mode 100644 fs/vboxsf/vboxsf_wrappers.c
>>>   create mode 100644 fs/vboxsf/vboxsf_wrappers.h
>>>   create mode 100644 fs/vboxsf/vfsmod.h
>>>   create mode 100644 include/uapi/linux/vbsfmount.h
>>
>>
[...]
>>> +++ b/fs/vboxsf/Kconfig
>>> @@ -0,0 +1,9 @@
>>> +config VBOXSF_FS
>>> +       tristate "VirtualBox guest shared folder (vboxsf) support"
>>
>>
>>
>> Don't know if you noticed, but calling your filesystem vboxsf
>> is quite odd name among other XXXfs beasts.
>
>
> Yes I noticed, note I'm only the guy pushing this upstream this code
> has a long out-of-tree history. FWIW the sf stand for "shared folder"
>
>> Will it be an option to re-brand this as vboxfs?
>> Even if it is too late or too much of a hustle to change the user visible
>> file_system_type name, I think changing the internal name is worth it.
>
>
> We can quite definitely not change the user-visible name, the mount
> arg changes Christoph Hellwig has requested are tricky enough wrt
> compatibility with the out-of-tree version most users use atm.
>
> The users will need updated userspace tools to deal with the mount arg
> changes, but that is as easy as checking for -EINVAL and trying again
> with the new style string args. But figuring out the right fstype name
> is rather more tricky and the mount binary name has been mount.vboxsf
> for ages...  So I would really like to keep the file_system_type name
> as vboxsf, at which point it seems counter-productive to me to rename
> the files / kernel-mode to vboxfs.
>

Well, its up to you and whoever merges this code, but I don't find this
rename counter-productive at all. Isn't the idea behind becoming an in-tree
fs, conforming to the way we do things in-the-tree?

Someone at Oracle once made a decision sometime in the past when that
code was out of tree and not among other fs without conforming to in-tree
standards. That decision affects the user visible fs name and I wasn't
suggesting to change that. That is what MODULE_ALIAS_FS is for.
But there is not really a good reason to carry the baggage of this decision
into the tree.

I don't know, maybe it's just me...

Cheers,
Amir.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ