lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 2 Mar 2018 13:18:29 -0800
From:   Andrew Morton <akpm@...ux-foundation.org>
To:     "Huang, Ying" <ying.huang@...el.com>
Cc:     linux-mm@...ck.org, linux-kernel@...r.kernel.org,
        Minchan Kim <minchan@...nel.org>,
        Michal Hocko <mhocko@...e.com>,
        Johannes Weiner <hannes@...xchg.org>,
        Mel Gorman <mgorman@...hsingularity.net>,
        Dave Hansen <dave.hansen@...el.com>,
        Arnd Bergmann <arnd@...db.de>,
        Chen Liqin <liqin.linux@...il.com>,
        Russell King <linux@...linux.org.uk>,
        Yoshinori Sato <ysato@...rs.sourceforge.jp>,
        "James E.J. Bottomley" <jejb@...isc-linux.org>,
        Guan Xuetao <gxt@...c.pku.edu.cn>,
        "David S. Miller" <davem@...emloft.net>,
        Chris Zankel <chris@...kel.net>,
        Vineet Gupta <vgupta@...opsys.com>,
        Ley Foon Tan <lftan@...era.com>,
        Ralf Baechle <ralf@...ux-mips.org>,
        Andi Kleen <ak@...ux.intel.com>
Subject: Re: [PATCH -mm] mm: Fix races between swapoff and flush dcache

On Fri,  2 Mar 2018 16:04:26 +0800 "Huang, Ying" <ying.huang@...el.com> wrote:

> From: Huang Ying <ying.huang@...el.com>
> 
> >From commit 4b3ef9daa4fc ("mm/swap: split swap cache into 64MB
> trunks") on, after swapoff, the address_space associated with the swap
> device will be freed.  So page_mapping() users which may touch the
> address_space need some kind of mechanism to prevent the address_space
> from being freed during accessing.
> 
> The dcache flushing functions (flush_dcache_page(), etc) in
> architecture specific code may access the address_space of swap device
> for anonymous pages in swap cache via page_mapping() function.  But in
> some cases there are no mechanisms to prevent the swap device from
> being swapoff, for example,
> 
> CPU1					CPU2
> __get_user_pages()			swapoff()
>   flush_dcache_page()
>     mapping = page_mapping()
>       ...				  exit_swap_address_space()
>       ...				    kvfree(spaces)
>       mapping_mapped(mapping)
> 
> The address space may be accessed after being freed.
> 
> But from cachetlb.txt and Russell King, flush_dcache_page() only care
> about file cache pages, for anonymous pages, flush_anon_page() should
> be used.  The implementation of flush_dcache_page() in all
> architectures follows this too.  They will check whether
> page_mapping() is NULL and whether mapping_mapped() is true to
> determine whether to flush the dcache immediately.  And they will use
> interval tree (mapping->i_mmap) to find all user space mappings.
> While mapping_mapped() and mapping->i_mmap isn't used by anonymous
> pages in swap cache at all.
> 
> So, to fix the race between swapoff and flush dcache, __page_mapping()
> is add to return the address_space for file cache pages and NULL
> otherwise.  All page_mapping() invoking in flush dcache functions are
> replaced with __page_mapping().
> 
> The patch is only build tested, because I have no machine with
> architecture other than x86.
> 
> ...
>
> +/*
> + * For file cache pages, return the address_space, otherwise return NULL
> + */
> +struct address_space *__page_mapping(struct page *page)
> +{
> +	struct address_space *mapping;
> +
> +	page = compound_head(page);
> +
> +	/* This happens if someone calls flush_dcache_page on slab page */
> +	if (unlikely(PageSlab(page)))
> +		return NULL;
> +
> +	mapping = page->mapping;
> +	if ((unsigned long)mapping & PAGE_MAPPING_ANON)
> +		return NULL;
> +
> +	return (void *)((unsigned long)mapping & ~PAGE_MAPPING_FLAGS);
> +}
> +

I think page_mapping_file() would be a better name.

And do we really need to duplicate page_mapping()?  Could it be

struct address_space *page_mapping_file(struct page *page)
{
	if (PageSwapCache(page))
		return NULL;
	return page_mapping(page);
}

(We don't need to run compound_head() here, do we?)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ