lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 15 May 2018 15:16:06 +0100
From:   David Howells <dhowells@...hat.com>
To:     Christoph Hellwig <hch@....de>
Cc:     dhowells@...hat.com, linux-afs@...ts.infradead.org,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/3] proc: Add a way to make network proc files writable

Christoph Hellwig <hch@....de> wrote:

> The other option I though about would be to hide a write callback
> in struct seq_operations, as that way all the existing helpers would
> just work.

That could work too.

> Btw one of the lines above is over 80 chars.  By using normal two
> tab indents for the continuations this would become a lot more readable:
> 
> struct proc_dir_entry *proc_create_net_data_write(const char *name,
> 		umode_t mode, struct proc_dir_entry *parent,
> 		const struct seq_operations *ops, proc_write_t write,
> 		unsigned int state_size, void *data)

Actually, it's less readable because the first argument isn't left-aligned
with the rest.  I'd suggest moving the first argument onto a separate line
also:

struct proc_dir_entry *proc_create_net_data_write(
	const char *name, umode_t mode, struct proc_dir_entry *parent,
	const struct seq_operations *ops, proc_write_t write,
	unsigned int state_size, void *data)

David

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ