lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sun, 3 Jun 2018 11:31:45 +0000
From:   Nicholas Mc Guire <der.herr@...r.at>
To:     Varsha Rao <rvarsha016@...il.com>
Cc:     Sathya Prakash <sathya.prakash@...adcom.com>,
        Chaitra P B <chaitra.basappa@...adcom.com>,
        Suganath Prabu Subramani 
        <suganath-prabu.subramani@...adcom.com>,
        MPT-FusionLinux.pdl@...adcom.com, linux-scsi@...r.kernel.org,
        linux-kernel@...r.kernel.org,
        Lukas Bulwahn <lukas.bulwahn@...il.com>
Subject: Re: [PATCH] message: fusion: Remove extra parentheses

On Sun, Jun 03, 2018 at 04:33:07PM +0530, Varsha Rao wrote:
> To fix clang warning of extraneous parentheses and check patch issue,
> remove extra parentheses and replace x == NULL with !x. Following
> coccinelle script is used to fix it.
> 
> @disable is_null,paren@
> expression e;
> statement s;
> @@
> if (
> - (e==NULL)
> +!e
>  )
> s
> 
> Signed-off-by: Varsha Rao <rvarsha016@...il.com>
Reviewed-by: Nicholas Mc Guire <der.herr@...r.at>

> ---
>  drivers/message/fusion/mptbase.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/message/fusion/mptbase.c b/drivers/message/fusion/mptbase.c
> index 51eb1b027963..3fe53b65c5fa 100644
> --- a/drivers/message/fusion/mptbase.c
> +++ b/drivers/message/fusion/mptbase.c
> @@ -335,11 +335,11 @@ static int mpt_remove_dead_ioc_func(void *arg)
>  	MPT_ADAPTER *ioc = (MPT_ADAPTER *)arg;
>  	struct pci_dev *pdev;
>  
> -	if ((ioc == NULL))
> +	if (!ioc)
>  		return -1;
>  
>  	pdev = ioc->pcidev;
> -	if ((pdev == NULL))
> +	if (!pdev)

This is of course equivalent - but note that in mptbase.c the "style"
== NULL is used in other places as well - so maybe it would be good to
change those as well or leave the == NULL in place for readability reasons.

>  		return -1;
>  
>  	pci_stop_and_remove_bus_device_locked(pdev);
> -- 
> 2.17.0
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ