lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Mon, 4 Jun 2018 11:55:12 +0100
From:   Charles Keepax <ckeepax@...nsource.cirrus.com>
To:     Andy Shevchenko <andy.shevchenko@...il.com>
CC:     Lee Jones <lee.jones@...aro.org>, <patches@...nsource.cirrus.com>,
        "Linux Kernel Mailing List" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] mfd: arizona: Don't use regmap_read_poll_timeout

On Mon, Jun 04, 2018 at 11:27:19AM +0100, Charles Keepax wrote:
> On Mon, Jun 04, 2018 at 12:40:37PM +0300, Andy Shevchenko wrote:
> > On Mon, Jun 4, 2018 at 8:44 AM, Lee Jones <lee.jones@...aro.org> wrote:
> > > On Fri, 11 May 2018, Charles Keepax wrote:
> > 
> > >> +     while (true) {
> > >> +             ret = regmap_read(arizona->regmap, reg, &val);
> > >>
> > >> +             if ((val & mask) == target)
> > >> +                     return 0;
> > >> +
> > >> +             if (ktime_compare(ktime_get(), timeout) > 0)
> > >> +                     break;
> > >> +
> > >> +             usleep_range(ARIZONA_REG_POLL_DELAY_US / 2,
> > >> +                          ARIZONA_REG_POLL_DELAY_US);
> > >> +     }
> > 
> > >From my point of view infinite loops not good for readability and maintenance.
> > Perhaps
> > 
> > do {
> > ...
> > } while (ktime_compare(...));
> > 
> > ?
> 
> I would rather not do it that way since then it becomes
> impossible to have a single poll with no delays happening. I can
> refactor to remove the while(true) but it will make the code a
> bit bigger, as I will probably need to duplicate some code
> outside the loop.
> 

Looking again I think it is fine if I do the ktime_compare at the top
of the loop though. Will respin.

Thanks,
Charles

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ