lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Wed,  8 Aug 2018 22:00:21 +0100
From:   John Whitmore <johnfwhitmore@...il.com>
To:     linux-kernel@...r.kernel.org
Cc:     devel@...verdev.osuosl.org, gregkh@...uxfoundation.org,
        John Whitmore <johnfwhitmore@...il.com>
Subject: [PATCH v2 00/15] staging:rtl8192u: Coding style

In this second version of the series I've replaced the macros
eqMacAddr and cpMacAddr with functions suggested by Joe Perches
<joe@...ches.com>

One issue with this change is that both of the functions now
used, defined in etherdevice.h, rely on the parameters being
u16 aligned. To achieve this I've re-ordered member variables
in two structures. This strikes me as being a bit shaky as
any change to a structure might upset that alignment.

Apart from that my only concern is renaming functions
which are exported symbols. As far as I can see they are
exported using EXPORT_SYMBOL but are not used anywhere.

John Whitmore (15):
  staging:rtl8192u: Remove macro eqMacAddr - Style
  staging:rtl8192u: Remove macro cpMacAddr - Style
  staging:rtl8192u: Replace magic number 6 with ETH_ALEN - Style
  staging:rtl8192u: Rename macro parameter __pIeeeDev - Style
  staging:rtl8192u: Rename __pTa - Style
  staging:rtl8192u: Lines should not end with a '(' - Style
  staging:rtl8192u: Rename Dot11d_Init - Style
  staging:rtl8192u: Rename Dot11d_Reset - Style
  staging:rtl8192u: Rename Dot11d_UpdateCountryIe - Style
  staging:rtl8192u: Rename dot11d_update_country_ie() parameters - Style
  staging:rtl8192u: Rename DOT11D_GetMaxTxPwrInDbm -  Style
  staging:rtl8192u: Rename Channel - Style
  staging:rtl8192u: Rename DOT11D_ScanComplete - Style
  staging:rtl8192u: Rename IsLegalChannel - Style
  staging:rtl8192u: Rename ToLegalChannel - Style

 drivers/staging/rtl8192u/ieee80211/dot11d.c   | 42 +++++-----
 drivers/staging/rtl8192u/ieee80211/dot11d.h   | 77 ++++++-------------
 .../staging/rtl8192u/ieee80211/ieee80211.h    | 11 +--
 .../staging/rtl8192u/ieee80211/ieee80211_rx.c | 10 +--
 .../rtl8192u/ieee80211/ieee80211_softmac.c    |  6 +-
 drivers/staging/rtl8192u/r8192U_core.c        | 10 +--
 drivers/staging/rtl8192u/r819xU_phy.c         |  2 +-
 7 files changed, 63 insertions(+), 95 deletions(-)

-- 
2.18.0

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ