lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 09 Aug 2018 18:07:47 -0700
From:   Joe Perches <joe@...ches.com>
To:     Rob Herring <robh@...nel.org>
Cc:     linux-kernel@...r.kernel.org,
        Andrew Morton <akpm@...ux-foundation.org>,
        Andy Whitcroft <apw@...onical.com>
Subject: Re: [PATCH] checkpatch: DT bindings should be a separate patch

On Thu, 2018-08-09 at 14:50 -0600, Rob Herring wrote:
> Devicetree bindings should be their own patch as documented in
> Documentation/devicetree/bindings/submitting-patches.txt section I.1.
> This is because bindings are logically independent from a driver
> implementation, they have a different maintainer (even though they often
> are applied via the same tree), and it makes for a cleaner history in
> the DT only tree created with git-filter-branch.
[]
> diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
[]
> @@ -2236,6 +2236,7 @@ sub process {
>  	our $clean = 1;
>  	my $signoff = 0;
>  	my $is_patch = 0;
> +	my $is_binding_patch = -1;
>  	my $in_header_lines = $file ? 0 : 1;
>  	my $in_commit_log = 0;		#Scanning lines before patch
>  	my $has_commit_log = 0;		#Encountered lines before patch
> @@ -2485,6 +2486,27 @@ sub process {
>  				$check = $check_orig;
>  			}
>  			$checklicenseline = 1;
> +
> +			if ($realfile !~ /MAINTAINERS/) {

Should probably be /^MAINTAINERS/

> +				my $mixed = 0;
> +				if ($realfile =~ /(Documentation\/devicetree|include\/dt-bindings).*/) {

This should have a ^ for the start of the filename and
generally, this is easier to read using m@...@ like:

				if ($realfile =~ m@^(?:Documentation/devicetree/|include/dt-bindings/)@) {

> +					if ($is_binding_patch == 0) {
> +						$mixed = 1;
> +					}
> +					$is_binding_patch = 1;
> +				} else {
> +					if ($is_binding_patch == 1) {
> +						$mixed = 1;
> +					}
> +					$is_binding_patch = 0;
> +				}

Perhaps there is simpler logic using an xor.

> +				if ($mixed == 1) {
> +					WARN("DT_SPLIT_BINDING_PATCH",
> +					     "DT binding docs and includes should be a separate patch\n");
> +				}

Perhaps add 'see: Documentation/devicetree/bindings/submitting-patches.txt'

> +			}


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ