lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 10 Aug 2018 13:57:06 -0300
From:   Arnaldo Carvalho de Melo <acme@...nel.org>
To:     Jiri Olsa <jolsa@...hat.com>
Cc:     Steven Rostedt <rostedt@...dmis.org>, linux-kernel@...r.kernel.org,
        linux-trace-devel@...r.kernel.org, Ingo Molnar <mingo@...nel.org>,
        Andrew Morton <akpm@...ux-foundation.org>,
        Peter Zijlstra <peterz@...radead.org>,
        Namhyung Kim <namhyung@...nel.org>,
        Masami Hiramatsu <mhiramat@...nel.org>,
        Alexander Shishkin <alexander.shishkin@...ux.intel.com>,
        Yordan Karadzhov <y.karadz@...il.com>,
        Tzvetomir Stoyanov <tz.stoyanov@...il.com>
Subject: Re: [RFC][PATCH 00/24] tools lib traceevent: Rename pevent to tep
 for preparation for library

Em Fri, Aug 10, 2018 at 03:14:01PM +0200, Jiri Olsa escreveu:
> On Fri, Aug 10, 2018 at 09:00:10AM -0400, Steven Rostedt wrote:
> > On Fri, 10 Aug 2018 11:21:37 +0200
> > Jiri Olsa <jolsa@...hat.com> wrote:
> > 
> > 
> > > > This is not complete. It is only one of many preparations to make
> > > > libtraceevent into a legitimate library. There's other naming conventions
> > > > that will be made. But for now, I would like to hear thoughts about
> > > > this change before we proceed further.  
> > > 
> > > right, I can see more things that needs rename, like in print_arg*,
> > > trace_* stuff and others
> > 
> > We are working on renaming the other data structures. As for the
> > "trace_" it is really "trace_seq_*" That's not going to get renamed. We
> > may move it to another header file. It matches the trace_seq_* code in
> > the kernel, and I would like to keep that the same.
> > 
> > > 
> > > I'm also getting weird make error when compiling in libtraceevent dir:
> > > 
> > >   [jolsa@...va traceevent]$ make
> > >     GEN      libtraceevent-dynamic-list
> > >   Either missing one of [ plugin_jbd2.so plugin_hrtimer.so plugin_kmem.so plugin_kvm.so plugin_mac80211.so plugin_sched_switch.so plugin_function.so plugin_xen.so plugin_scsi.so plugin_cfg80211.so] or bad version of nm
> > > 
> > > but that seems to be there even without your patchset,
> > > so probably something we should look into
> > 
> > Hmm, OK, I'll try to look into that later.
> > 
> > > 
> > > other than that it looks ok to me
> > 
> > Great!
> > 
> > > 
> > > once this is done, we can move forward to put this
> > > to kernel-tools-libs-devel rpm
> > 
> > For this patch series, do you want to take the patch set, or just pull
> > from my branch?
> 
> Arnaldo takes care of that, but I guess pulling from branch is the prefered way

I'll try pulling and building it automatically patch by patch,

- Arnaldo

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux - Powered by OpenVZ