lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 18 Aug 2018 08:07:51 -0700
From:   Joe Perches <joe@...ches.com>
To:     Bhaskar Singh <bhaskar.kernel@...il.com>,
        zhong jiang <zhongjiang@...wei.com>
Cc:     devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org,
        gregkh@...uxfoundation.org
Subject: Re: [PATCH] staging: rtl8188eu: Type cast function argument

On Sat, 2018-08-18 at 20:28 +0530, Bhaskar Singh wrote:
> On Sat, Aug 18, 2018 at 10:33:31PM +0800, zhong jiang wrote:
> > On 2018/8/18 22:24, Bhaskar Singh wrote:
> > > This patch might suppress some warrning.
> > > 
> > > The function prototype of rtw_malloc2d is
> > > 
> > > void *rtw_malloc2d(int h, int w, int size)
> > > 
> > > This patch also resolves the checkpatch.pl warning
> > > 
> > > WARNING: line over 80 characters

Please look deeper at the code than checkpatch.

This function is used exactly once and could
likely be removed and coded inline instead to
improve readability.

> > > Signed-off-by: Bhaskar Singh <bhaskar.kernel@...il.com>
> > > ---
> > >  drivers/staging/rtl8188eu/core/rtw_efuse.c | 3 ++-
> > >  1 file changed, 2 insertions(+), 1 deletion(-)
> > > 
> > > diff --git a/drivers/staging/rtl8188eu/core/rtw_efuse.c b/drivers/staging/rtl8188eu/core/rtw_efuse.c
> > > index 0fd306a808c4..735d654b2844 100644
> > > --- a/drivers/staging/rtl8188eu/core/rtw_efuse.c
> > > +++ b/drivers/staging/rtl8188eu/core/rtw_efuse.c
> > > @@ -91,7 +91,8 @@ efuse_phymap_to_logical(u8 *phymap, u16 _offset, u16 _size_byte, u8  *pbuf)
> > >  	if (!efuseTbl)
> > >  		return;
> > >  
> > > -	eFuseWord = (u16 **)rtw_malloc2d(EFUSE_MAX_SECTION_88E, EFUSE_MAX_WORD_UNIT, sizeof(u16));
> > > +	eFuseWord = (u16 **)rtw_malloc2d(EFUSE_MAX_SECTION_88E,
> > > +			EFUSE_MAX_WORD_UNIT, (int)sizeof(u16));
> > >  
> > 
> >   You should be align with left parenthesis.
> > 
> >  Thanks,
> >  zhong jiang
> > > 	if (!eFuseWord) {
> > >  		DBG_88E("%s: alloc eFuseWord fail!\n", __func__);
> > >  		goto eFuseWord_failed;
> > 
> > 
> 
> why post-commit doesn't give some warrning about that (because commits are checked by
> post-commit script)?
> Do I need to resend the patch?
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ