lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 24 Jan 2019 11:39:22 +0100
From:   "Rafael J. Wysocki" <rjw@...ysocki.net>
To:     Yangtao Li <tiny.windzz@...il.com>
Cc:     daniel.lezcano@...aro.org, linux-pm@...r.kernel.org,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH] cpuidle: use BIT() for idle state flags and remove CPUIDLE_DRIVER_FLAGS_MASK

On Tuesday, January 15, 2019 6:22:10 PM CET Yangtao Li wrote:
> Use BIT() macro to do a small tidy-up. The CPUIDLE_DRIVER_FLAGS_MASK
>  is not being used, so remove it.
> 
> Signed-off-by: Yangtao Li <tiny.windzz@...il.com>
> ---
>  include/linux/cpuidle.h | 8 +++-----
>  1 file changed, 3 insertions(+), 5 deletions(-)
> 
> diff --git a/include/linux/cpuidle.h b/include/linux/cpuidle.h
> index 4dff74f48d4b..3b39472324a3 100644
> --- a/include/linux/cpuidle.h
> +++ b/include/linux/cpuidle.h
> @@ -69,11 +69,9 @@ struct cpuidle_state {
>  
>  /* Idle State Flags */
>  #define CPUIDLE_FLAG_NONE       (0x00)
> -#define CPUIDLE_FLAG_POLLING	(0x01) /* polling state */
> -#define CPUIDLE_FLAG_COUPLED	(0x02) /* state applies to multiple cpus */
> -#define CPUIDLE_FLAG_TIMER_STOP (0x04)  /* timer is stopped on this state */
> -
> -#define CPUIDLE_DRIVER_FLAGS_MASK (0xFFFF0000)
> +#define CPUIDLE_FLAG_POLLING	BIT(0) /* polling state */
> +#define CPUIDLE_FLAG_COUPLED	BIT(1) /* state applies to multiple cpus */
> +#define CPUIDLE_FLAG_TIMER_STOP BIT(2) /* timer is stopped on this state */
>  
>  struct cpuidle_device_kobj;
>  struct cpuidle_state_kobj;
> 

Applied, even though I'm not a big fan of conversions from open-coded
values (as long as they are correct) to BIT(), unless you are going to
add a new flag and want to use BIT() for that, because that doesn't really
matter and only makes the lives of 'git blame' users harder.

However, in this particular case, the removal of the unused symbol is
legitimate IMO.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ