lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Thu, 18 Jan 2024 00:56:43 +0000
From: Thinh Nguyen <Thinh.Nguyen@...opsys.com>
To: UTTKARSH AGGARWAL <quic_uaggarwa@...cinc.com>
CC: Kuen-Han Tsai <khtsai@...gle.com>,
        Thinh Nguyen <Thinh.Nguyen@...opsys.com>,
        Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
        "linux-usb@...r.kernel.org" <linux-usb@...r.kernel.org>
Subject: Re: [RFC PATCH] usb: dwc3: gadget: Fix NULL pointer dereference in
 dwc3_gadget_suspend

On Wed, Jan 17, 2024, UTTKARSH AGGARWAL wrote:
> 
> On 1/17/2024 2:52 PM, UTTKARSH AGGARWAL wrote:
> > 
> > On 1/17/2024 12:47 PM, Kuen-Han Tsai wrote:
> > > >          ret = dwc3_gadget_soft_disconnect(dwc);
> > > >          if (ret)
> > > >                  goto err;
> > > For improved readability, we can remove the goto statement and move
> > > the error handling logic here.
> > 
> > Hi Kuen-Han,
> > 
> > Thanks for the suggestion.
> > Does this looks good to you ?
> > 
> >    int ret = dwc3_gadget_soft_disconnect(dwc);if (ret) {        if
> > (dwc->softconnect)            dwc3_gadget_soft_connect(dwc);
> > 
> >        return ret;    }    spin_lock_irqsave(&dwc->lock, flags);    if
> > (dwc->gadget_driver)  dwc3_disconnect_gadget(dwc);
> >  spin_unlock_irqrestore(&dwc->lock, flags);
> 
> Sorry for the mistake.
> 
> int ret = dwc3_gadget_soft_disconnect(dwc);
> 
> if (ret) {
> 
>       if (dwc->softconnect)
> 
>                  dwc3_gadget_soft_connect(dwc);
> 
>       return ret;
> 
> }
> 
> spin_lock_irqsave(&dwc->lock, flags);
> 
> if (dwc->gadget_driver)
> 
>        dwc3_disconnect_gadget(dwc);
> 
> spin_unlock_irqrestore(&dwc->lock, flags);
> 

Please only make one logical fix per change. If any unrelated refactor
or style change is needed, keep it to a separate commit.

Thanks,
Thinh

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ