lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 27 May 2008 15:47:54 +0100
From:	Ben Hutchings <bhutchings@...arflare.com>
To:	Eilon Greenstein <eilong@...adcom.com>
Cc:	netdev <netdev@...r.kernel.org>, jeff@...zik.org,
	davem@...emloft.net, Vladislav Zolotarov <vladz@...adcom.com>,
	Eliezer Tamir <eliezert@...adcom.com>
Subject: Re: [PATCH net-next 6/12]bnx2x: Add TPA, Broadcoms HW LRO

Eilon Greenstein wrote:
> bnx2x: Add TPA, Broadcoms HW LRO
> 
> Signed-off-by: Vladislav Zolotarov <vladz@...adcom.com>
> Signed-off-by: Eliezer Tamir <eliezert@...adcom.com>

What's with the byte order marks here?

[...]
> diff --git a/drivers/net/bnx2x_main.c b/drivers/net/bnx2x_main.c
> index 20ecfcb..366764e 100644
> --- a/drivers/net/bnx2x_main.c
> +++ b/drivers/net/bnx2x_main.c
> @@ -84,6 +84,7 @@ MODULE_VERSION(DRV_MODULE_VERSION);
>  static int use_inta;
>  static int poll;
>  static int debug;
> +static int disable_tpa;
>  static int nomcp;
>  static int load_count[3]; /* 0 common, 1 port0, 2 port1 */
>  static int use_multi;
> @@ -91,6 +92,7 @@ static int use_multi;
>  module_param(use_inta, int, 0);
>  module_param(poll, int, 0);
>  module_param(debug, int, 0);
> +module_param(disable_tpa, int, 0);
>  module_param(nomcp, int, 0);
>  MODULE_PARM_DESC(use_inta, "use INT#A instead of MSI-X");
>  MODULE_PARM_DESC(poll, "use polling (for debug)");

It's important that people are able to see how to disable LRO.  Using a
different name for it, and no module parameter description, really doesn't
help.

You should also implement ethtool get_flags and set_flags methods so that
LRO can be turned on and off later (at least once the ethtool command gets
patched, hint hint).

Ben.

-- 
Ben Hutchings, Senior Software Engineer, Solarflare Communications
Not speaking for my employer; that's the marketing department's job.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ