lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 15 Dec 2009 17:00:04 +0100
From:	stefano babic <stefano.babic@...ic.homelinux.org>
To:	sjur.brandeland@...ricsson.com
CC:	netdev@...r.kernel.org, randy.dunlap@...cle.com,
	kim.xx.lilliestierna@...ricsson.com,
	christian.bejram@...ricsson.com, daniel.martensson@...ricsson.com
Subject: Re: [RFC PATCH v3  3/8] CAIF Protocol Stack

sjur.brandeland@...ricsson.com wrote:
> diff --git a/include/net/caif/caif_chr.h b/include/net/caif/caif_chr.h
> new file mode 100644
> index 0000000..ebd89f8
> --- /dev/null
> +++ b/include/net/caif/caif_chr.h

Only a question of taste, but there is no chr device anymore, maybe
another name for the file should be more appropriate.

> +struct caif_service_config;
> +
> +enum cf_chr_dev_type {
> +	CFDEVTYPE_CHR,
> +	CFDEVTYPE_TTY,
> +	CFDEVTYPE_NET
> +};
> +
> +extern int serial_use_stx;
> +extern int (*netdev_mgmt_func) (int action, union caif_action *param);
> +int caifdev_phy_reg(struct layer *phyif, struct cfcnfg_phy_mgmt *mgmt);
> +int caifdev_phy_instanciate(struct cfcnfg_phy_config *phy_config);
> +int caifdev_phy_register(struct layer *phyif,
> +			 enum cfcnfg_phy_type phy_type,
> +			 enum cfcnfg_phy_preference phy_pref);
> +int caifdev_phy_unregister(struct layer *phyif);
> +int caifdev_phy_loop_register(struct layer *phyif,
> +			      enum cfcnfg_phy_type phy_type);
> +int caifdev_phy_spi_xmitlen(struct cfspil *layr);
> +struct cfpkt *caifdev_phy_spi_getxmitpkt(struct cfspil *layr);

All these functions seem obsolete.

> +int caif_register_chrdev(int (*chrdev_mgmt)
> +			(int action, union caif_action *param));
> +void caif_unregister_chrdev(void);

Obsolete, too.

> diff --git a/include/net/caif/caif_config_util.h b/include/net/caif/caif_config_util.h
> new file mode 100644
> index 0000000..cdc1443
> --- /dev/null
> +++ b/include/net/caif/caif_config_util.h
> @@ -0,0 +1,20 @@
> +/*
> + * Copyright (C) ST-Ericsson AB 2009
> + * Author:	Daniel Martensson / Daniel.Martensson@...ricsson.com
> + * License terms: GNU General Public License (GPL) version 2
> + */
> +
> +#ifndef CAIF_CONFIG_UTIL_H_
> +#define CAIF_CONFIG_UTIL_H_
> +
> +#include <linux/caif/caif_config.h>
> +#include <linux/caif/caif_ioctl.h>
> +#include <net/caif/generic/cfcnfg.h>
> +#include <net/caif/generic/cfctrl.h>
> +#include <net/caif/caif_actions.h>
> +
> +int channel_config_2_link_param(struct cfcnfg *cnfg,
> +				struct caif_channel_config *s,
> +				struct cfctrl_link_param *l);
> +
> +#endif

Do we need an extra-header only to set the prototype of a single
function ? Probably can we move it into another header file.

Stefano

-- 
stefano <stefano.babic@...ic.homelinux.org>
GPG Key: 0x55814DDE
Fingerprint 4E85 2A66 4CBA 497A 2A7B D3BF 5973 F216 5581 4DDE
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ