lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 9 Jul 2010 08:33:24 -0700
From:	"Rose, Gregory V" <gregory.v.rose@...el.com>
To:	Stefan Assmann <sassmann@...hat.com>, Arnd Bergmann <arnd@...db.de>
CC:	netdev <netdev@...r.kernel.org>,
	"e1000-devel@...ts.sourceforge.net" 
	<e1000-devel@...ts.sourceforge.net>,
	"Duyck, Alexander H" <alexander.h.duyck@...el.com>,
	"Kirsher, Jeffrey T" <jeffrey.t.kirsher@...el.com>,
	Andy Gospodarek <gospo@...hat.com>
Subject: RE: [PATCH] igbvf: avoid name clash between PF and VF

>-----Original Message-----
>From: Stefan Assmann [mailto:sassmann@...hat.com]
>Sent: Friday, July 09, 2010 2:32 AM
>To: Arnd Bergmann
>Cc: netdev; e1000-devel@...ts.sourceforge.net; Duyck, Alexander H; Rose,
>Gregory V; Kirsher, Jeffrey T; Andy Gospodarek
>Subject: Re: [PATCH] igbvf: avoid name clash between PF and VF
>
>On 08.07.2010 15:41, Arnd Bergmann wrote:
>> On Wednesday 30 June 2010, Stefan Assmann wrote:
>>> diff --git a/drivers/net/igbvf/netdev.c b/drivers/net/igbvf/netdev.c
>>> index 5e2b2a8..2fb665b 100644
>>> --- a/drivers/net/igbvf/netdev.c
>>> +++ b/drivers/net/igbvf/netdev.c
>>> @@ -2787,7 +2787,7 @@ static int __devinit igbvf_probe(struct pci_dev
>*pdev,
>>>         netif_carrier_off(netdev);
>>>         netif_stop_queue(netdev);
>>>
>>> -       strcpy(netdev->name, "eth%d");
>>> +       strcpy(netdev->name, "veth%d");
>>>         err = register_netdev(netdev);
>>>         if (err)
>>>                 goto err_hw_init;
>>
>> Note that 'veth' is the name used for a virtual ethernet pair by
>> drivers/net/veth.c. If a variant of your patch gets applied, it would
>> probably be useful to use a different naming scheme to avoid confusion
>> with the veth driver.
>
>Good point!
>Greg suggested vfeth, that should be more descriptive and unique.
>
>  Stefan
>---
>diff --git a/drivers/net/igbvf/netdev.c b/drivers/net/igbvf/netdev.c
>index 5e2b2a8..4d02af8 100644
>--- a/drivers/net/igbvf/netdev.c
>+++ b/drivers/net/igbvf/netdev.c
>@@ -2787,7 +2787,7 @@ static int __devinit igbvf_probe(struct pci_dev
>*pdev,
> 	netif_carrier_off(netdev);
> 	netif_stop_queue(netdev);
>
>-	strcpy(netdev->name, "eth%d");
>+	strcpy(netdev->name, "vfeth%d");
> 	err = register_netdev(netdev);
> 	if (err)
> 		goto err_hw_init;

Acked-by: Greg Rose <gregory.v.rose@...el.com>

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists