lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 22 Jun 2012 19:34:56 +0200
From:	Bjørn Mork <bjorn@...k.no>
To:	Dan Carpenter <dan.carpenter@...cle.com>
Cc:	netdev@...r.kernel.org
Subject: Re: net: qmi_wwan: bind to both control and data interface

Dan Carpenter <dan.carpenter@...cle.com> writes:
> On Fri, Jun 22, 2012 at 06:27:17PM +0200, Bjørn Mork wrote:
>
>> Thanks for the notification, but this was intentional while touching the
>> code anyway.  The test always was redundant because the parsing code
>> ensure that cdc_union cannot be NULL at that point.
>> 
>
> Yeah.  I see that now.  I think it would be more readable if the
> check were rewritten like this.  That way you can see immediately
> that it's checking for USB_CDC_UNION_TYPE without scrolling back and
> forth in the code.
>
> diff --git a/drivers/net/usb/qmi_wwan.c b/drivers/net/usb/qmi_wwan.c
> index f1e7791..23cb13c 100644
> --- a/drivers/net/usb/qmi_wwan.c
> +++ b/drivers/net/usb/qmi_wwan.c
> @@ -129,7 +129,6 @@ static int qmi_wwan_bind(struct usbnet *dev, struct usb_interface *intf)
>  	struct usb_interface_descriptor *desc = &intf->cur_altsetting->desc;
>  	struct usb_cdc_union_desc *cdc_union = NULL;
>  	struct usb_cdc_ether_desc *cdc_ether = NULL;
> -	u32 required = 1 << USB_CDC_HEADER_TYPE | 1 << USB_CDC_UNION_TYPE;
>  	u32 found = 0;
>  	struct usb_driver *driver = driver_of(intf);
>  	struct qmi_wwan_state *info = (void *)&dev->data;
> @@ -197,7 +196,8 @@ next_desc:
>  	}
>  
>  	/* did we find all the required ones? */
> -	if ((found & required) != required) {
> +	if (!(found & (1 << USB_CDC_HEADER_TYPE)) ||
> +	    !(found & (1 << USB_CDC_UNION_TYPE))) {
>  		dev_err(&intf->dev, "CDC functional descriptors missing\n");
>  		goto err;
>  	}


I fully agree.  Feel free to add my

Acked-by: Bjørn Mork <bjorn@...k.no>

if you want to submit that.



Bjørn
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ