lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Sun, 23 Jun 2013 18:45:14 -0700 (PDT)
From:	David Miller <davem@...emloft.net>
To:	dlstevens@...ibm.com
Cc:	pshelar@...ira.com, dev@...nvswitch.org, netdev@...r.kernel.org,
	netdev-owner@...r.kernel.org
Subject: Re: [PATCH net-next 5/8] vxlan: Factor out vxlan send api.

From: David Stevens <dlstevens@...ibm.com>
Date: Thu, 20 Jun 2013 08:46:42 -0400

>> From: Pravin B Shelar <pshelar@...ira.com>
>  
> 
>> @@ -1205,13 +1222,13 @@ static netdev_tx_t vxlan_xmit(struct sk_buff
>> *skb, struct net_device *dev)
>> 
>>        skb1 = skb_clone(skb, GFP_ATOMIC);
>>        if (skb1) {
>> -         rc1 = vxlan_xmit_one(skb1, dev, rdst, did_rsc);
>> +         rc1 = __vxlan_xmit(skb1, dev, rdst, did_rsc);
>>           if (rc == NETDEV_TX_OK)
>>              rc = rc1;
>>        }
>>     }
>> 
>> -   rc1 = vxlan_xmit_one(skb, dev, rdst0, did_rsc);
>> +   rc1 = __vxlan_xmit(skb, dev, rdst0, did_rsc);
>>     if (rc == NETDEV_TX_OK)
>>        rc = rc1;
>>     return rc;
> 
> You're changing the name of the function that sends a
> packet to one destination because you think "__vxlan_xmit"
> is more descriptive than "vxlan_xmit_one" ?

Agreed, this is rediculous.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ