lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 4 Sep 2013 00:59:13 +0000
From:	"Nelson, Shannon" <shannon.nelson@...el.com>
To:	Joe Perches <joe@...ches.com>,
	"Kirsher, Jeffrey T" <jeffrey.t.kirsher@...el.com>
CC:	"davem@...emloft.net" <davem@...emloft.net>,
	"Brandeburg, Jesse" <jesse.brandeburg@...el.com>,
	"netdev@...r.kernel.org" <netdev@...r.kernel.org>,
	"gospo@...hat.com" <gospo@...hat.com>,
	"sassmann@...hat.com" <sassmann@...hat.com>,
	"Waskiewicz Jr, Peter P" <peter.p.waskiewicz.jr@...el.com>,
	"e1000-devel@...ts.sourceforge.net" 
	<e1000-devel@...ts.sourceforge.net>
Subject: RE: [net-next v3 1/8] i40e: main driver core

> -----Original Message-----
> From: Joe Perches [mailto:joe@...ches.com]
> Sent: Friday, August 30, 2013 9:33 AM
> 

Hi Joe, thanks for your comments, and we're working through another version to be posted Real Soon.  In the meantime I thought I'd respond to a couple specific comments.

> > +#define DRV_KERN "-k"
> > +
> > +#define DRV_VERSION_MAJOR 0
> > +#define DRV_VERSION_MINOR 3
> > +#define DRV_VERSION_BUILD 8
> > +#define DRV_VERSION __stringify(DRV_VERSION_MAJOR) "." \
> > +	     __stringify(DRV_VERSION_MINOR) "." \
> > +	     __stringify(DRV_VERSION_BUILD)    DRV_KERN
> 
> does "-k" add/signify anything useful?

The "-k" helps us to quickly spot that a customer is asking us about the upstream version of our driver and not an out-of-tree (e.g. SourceForge) version.

[...]


> 
> > +/**
> > + * i40e_get_netdev_stats_struct - Get statistics for netdev interface
> > + * @netdev: network interface device structure
> > + *
> > + * Returns the address of the device statistics structure.
> > + * The statistics are actually updated from the service task.
> > + **/
> > +static struct rtnl_link_stats64 *i40e_get_netdev_stats_struct(
> > +					     struct net_device *netdev,
> > +					     struct rtnl_link_stats64 *storage)
> 
> An alternative bsd declaration style might be
> more readable for these very long types and names.
> 
> static struct rtnl_link_stats64 *
> i40e_get_netdev_stats_struct(struct net_device *netdev,
> 			     struct rtnl_link_stats64 *storage)

We're trying to stay consistent in kernel function styles, stay within standard checkpatch restrictions, and keep the code readable and maintainable, which all together make for some difficult choices.  No matter which way we go on some of these decisions, we run into the painfully gray opinion areas of how someone else might have solved the problems.

sln

--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists