lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 17 Apr 2014 17:05:24 +0200
From:	Jiri Pirko <jiri@...nulli.us>
To:	Stephen Hemminger <stephen@...workplumber.org>
Cc:	netdev@...r.kernel.org, davem@...emloft.net, nhorman@...driver.com,
	andy@...yhouse.net, tgraf@...g.ch, dborkman@...hat.com,
	ogerlitz@...lanox.com, jesse@...ira.com, pshelar@...ira.com,
	azhou@...ira.com, ben@...adent.org.uk, jeffrey.t.kirsher@...el.com,
	vyasevic@...hat.com, xiyou.wangcong@...il.com,
	john.r.fastabend@...el.com, edumazet@...gle.com, jhs@...atatu.com,
	sfeldma@...ulusnetworks.com, f.fainelli@...il.com,
	roopa@...ulusnetworks.com, linville@...driver.com,
	dev@...nvswitch.org, jasowang@...hat.com, ebiederm@...ssion.com,
	nicolas.dichtel@...nd.com, ryazanov.s.a@...il.com,
	buytenh@...tstofly.org, aviadr@...lanox.com, nbd@...nwrt.org,
	alexei.starovoitov@...il.com, Neil.Jerram@...aswitch.com
Subject: Re: [patch net-next RFC v3 02/10] net: rename netdev_phys_port_id to
 more generic name

Thu, Apr 17, 2014 at 05:01:10PM CEST, stephen@...workplumber.org wrote:
>On Thu, 17 Apr 2014 14:14:29 +0200
>Jiri Pirko <jiri@...nulli.us> wrote:
>
>> So this can be reused for identification of other "items" as well.
>> 
>> Signed-off-by: Jiri Pirko <jiri@...nulli.us>
>> ---
>>  drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c |  2 +-
>>  drivers/net/ethernet/mellanox/mlx4/en_netdev.c   |  2 +-
>>  drivers/net/ethernet/qlogic/qlcnic/qlcnic_main.c |  2 +-
>>  include/linux/netdevice.h                        | 16 ++++++++--------
>>  net/core/dev.c                                   |  2 +-
>>  net/core/net-sysfs.c                             |  2 +-
>>  net/core/rtnetlink.c                             |  6 +++---
>>  7 files changed, 16 insertions(+), 16 deletions(-)
>> 
>> diff --git a/drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c b/drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c
>> index a78edac..a4b25b1 100644
>> --- a/drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c
>> +++ b/drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c
>> @@ -12360,7 +12360,7 @@ static int bnx2x_validate_addr(struct net_device *dev)
>>  }
>>  
>>  static int bnx2x_get_phys_port_id(struct net_device *netdev,
>> -				  struct netdev_phys_port_id *ppid)
>> +				  struct netdev_phys_item_id *ppid)
>>  {
>>  	struct bnx2x *bp = netdev_priv(netdev);
>>  
>> diff --git a/drivers/net/ethernet/mellanox/mlx4/en_netdev.c b/drivers/net/ethernet/mellanox/mlx4/en_netdev.c
>> index f085c2d..e784bb4 100644
>> --- a/drivers/net/ethernet/mellanox/mlx4/en_netdev.c
>> +++ b/drivers/net/ethernet/mellanox/mlx4/en_netdev.c
>> @@ -2251,7 +2251,7 @@ static int mlx4_en_set_vf_link_state(struct net_device *dev, int vf, int link_st
>>  
>>  #define PORT_ID_BYTE_LEN 8
>>  static int mlx4_en_get_phys_port_id(struct net_device *dev,
>> -				    struct netdev_phys_port_id *ppid)
>> +				    struct netdev_phys_item_id *ppid)
>>  {
>>  	struct mlx4_en_priv *priv = netdev_priv(dev);
>>  	struct mlx4_dev *mdev = priv->mdev->dev;
>> diff --git a/drivers/net/ethernet/qlogic/qlcnic/qlcnic_main.c b/drivers/net/ethernet/qlogic/qlcnic/qlcnic_main.c
>> index 309d056..55af16a 100644
>> --- a/drivers/net/ethernet/qlogic/qlcnic/qlcnic_main.c
>> +++ b/drivers/net/ethernet/qlogic/qlcnic/qlcnic_main.c
>> @@ -450,7 +450,7 @@ static void qlcnic_82xx_cancel_idc_work(struct qlcnic_adapter *adapter)
>>  }
>>  
>>  static int qlcnic_get_phys_port_id(struct net_device *netdev,
>> -				   struct netdev_phys_port_id *ppid)
>> +				   struct netdev_phys_item_id *ppid)
>>  {
>>  	struct qlcnic_adapter *adapter = netdev_priv(netdev);
>>  	struct qlcnic_hardware_context *ahw = adapter->ahw;
>> diff --git a/include/linux/netdevice.h b/include/linux/netdevice.h
>> index 775cc95..8cf4f5e 100644
>> --- a/include/linux/netdevice.h
>> +++ b/include/linux/netdevice.h
>> @@ -735,13 +735,13 @@ struct netdev_fcoe_hbainfo {
>>  };
>>  #endif
>>  
>> -#define MAX_PHYS_PORT_ID_LEN 32
>> +#define MAX_PHYS_ITEM_ID_LEN 32
>>  
>
>Why the rename?


I use the same struct in "net: introduce generic switch devices support"
to identify switch. So that is no longer only a "port id"
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ