lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date: Mon, 07 Dec 2009 16:04:01 +0100
From: security@...driva.com
To: bugtraq@...urityfocus.com
Subject: [ MDVSA-2008:233-1 ] libcdaudio


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                       MDVSA-2008:233-1
 http://www.mandriva.com/security/
 _______________________________________________________________________

 Package : libcdaudio
 Date    : December 7, 2008
 Affected: 2008.0
 _______________________________________________________________________

 Problem Description:

 A heap overflow was found in the CDDB retrieval code of libcdaudio,
 which could result in the execution of arbitrary code (CVE-2008-5030).
 
 In addition, the fixes for CVE-2005-0706 were not applied to newer
 libcdaudio packages as shipped with Mandriva Linux, so the patch to fix
 that issue has been applied to 2008.1 and 2009.0 (this was originally
 fixed in MDKSA-2005:075).  This issue is a buffer overflow flaw found
 by Joseph VanAndel.  Corporate 3.0 has this fix already applied.
 
 The updated packages have been patched to prevent these issues.

 Update:

 Packages for 2008.0 are being provided due to extended support for
 Corporate products.
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0706
 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-5030
 _______________________________________________________________________

 Updated Packages:

 Mandriva Linux 2008.0:
 03b2d7de482f9e8a2b280a9960f53b89  2008.0/i586/libcdaudio1-0.99.12-4.1mdv2008.0.i586.rpm
 fcda23d9905970f43499be8666d24694  2008.0/i586/libcdaudio1-devel-0.99.12-4.1mdv2008.0.i586.rpm 
 9b677065ed44a894a82821902bd4d2e3  2008.0/SRPMS/libcdaudio-0.99.12-4.1mdv2008.0.src.rpm

 Mandriva Linux 2008.0/X86_64:
 5ba975905fc5f3bc4471017bad98a683  2008.0/x86_64/lib64cdaudio1-0.99.12-4.1mdv2008.0.x86_64.rpm
 f8c3bc6d98dfb11dfd947f138f9fb653  2008.0/x86_64/lib64cdaudio1-devel-0.99.12-4.1mdv2008.0.x86_64.rpm 
 9b677065ed44a894a82821902bd4d2e3  2008.0/SRPMS/libcdaudio-0.99.12-4.1mdv2008.0.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFLHO3mmqjQ0CJFipgRAr6hAKDEE4BI0iskkNXnsdFPwo4YWSXP2QCdFivZ
G/aOwVBboFusu134luJ913I=
=TBr+
-----END PGP SIGNATURE-----

Powered by blists - more mailing lists