lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date: Wed, 05 Jan 2011 23:18:09 +0000
From: Stefan Fritsch <sf@...ian.org>
To: bugtraq@...urityfocus.com
Subject: [SECURITY] [DSA-2141-1] New openssl packages fix protocol design flaw

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ------------------------------------------------------------------------
Debian Security Advisory DSA-2141-1                  security@...ian.org
http://www.debian.org/security/                           Stefan Fritsch
January 06, 2011                      http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package        : openssl
Vulnerability  : SSL/TLS insecure renegotiation protocol design flaw
Problem type   : remote
Debian-specific: no
CVE ID         : CVE-2009-3555 CVE-2010-4180
Debian Bug     : 555829

CVE-2009-3555:

Marsh Ray, Steve Dispensa, and Martin Rex discovered a flaw in the TLS
and SSLv3 protocols. If an attacker could perform a man in the middle
attack at the start of a TLS connection, the attacker could inject
arbitrary content at the beginning of the user's session. This update
adds backported support for the new RFC5746 renegotiation extension
which fixes this issue.

If openssl is used in a server application, it will by default no
longer accept renegotiation from clients that do not support the
RFC5746 secure renegotiation extension. A separate advisory will add
RFC5746 support for nss, the security library used by the iceweasel
web browser. For apache2, there will be an update which allows to
re-enable insecure renegotiation.

This version of openssl is not compatible with older versions of tor.
You have to use at least tor version 0.2.1.26-1~lenny+1, which has
been included in the point release 5.0.7 of Debian stable.

Currently we are not aware of other software with similar compatibility
problems.


CVE-2010-4180:
 
In addition, this update fixes a flaw that allowed a client to bypass
restrictions configured in the server for the used cipher suite.


For the stable distribution (lenny), this problem has been fixed
in version 0.9.8g-15+lenny11.

For the unstable distribution (sid), and the testing distribution
(squeeze), this problem has been fixed in version 0.9.8o-4.

We recommend that you upgrade your openssl package.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce@...ts.debian.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iD8DBQFNJPe+bxelr8HyTqQRAgz7AJ9zP01uGq9aeyPPWJRDit9RGiLH7wCeL2yb
ER5vbU2hWhtwTUhj3isjjds=
=XNn8
-----END PGP SIGNATURE-----

Powered by blists - more mailing lists