lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date: Fri, 21 Aug 2015 10:19:32 -0700
From: Suyog Rao <suyog@...stic.co>
To: bugtraq@...urityfocus.com
Subject: Logstash vulnerability CVE-2015-5619

Summary:
Logstash 1.5.3 and prior versions are vulnerable to a SSL/TLS security
issue which allows an attacker to successfully implement a man in the
middle attack. This vulnerability is not present in the initial
installation of Logstash. This insecurity is exposed when users
configure Lumberjack output to connect two Logstash instances. In such
deployments, a Logstash instance is used to collect logs from a
webserver and securely transmit them to a central Logstash instance to
perform additional filtering and storing.

Note: Communication between Logstash Forwarder and Lumberjack Input in
Logstash is not affected by this vulnerability.

We have been assigned CVE-2015-5619 for this issue.

Fixed versions:
Version 1.5.4 and 1.4.5 has been patched with a fix that addresses
this vulnerability.

Remediation:
Users that currently use Logstash with the Lumberjack output or may
want to use it in the future should upgrade to 1.5.4 or 1.4.5.

Users that do not want to upgrade can address the vulnerability by
disabling the Lumberjack output.

Credit:
Markus Frosch reported this issue.

CVSS
Overall CVSS score: 4.3

Powered by blists - more mailing lists