lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date: Mon, 25 Mar 2019 11:57:03 +1100
From: Atlassian <security@...assian.com>
To: bugtraq@...urityfocus.com
Subject: Atlassian - Confluence Security Advisory - 2019-03-20

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

This email refers to the advisory found at
https://confluence.atlassian.com/display/DOC/Confluence+Security+Advisory+-+2019-03-20
.


CVE ID:

* CVE-2019-3395.
* CVE-2019-3396.


Product: Confluence Server and Confluence Data Center.

Affected Confluence Server and Confluence Data Center product versions:

6.6.0 <= version < 6.6.12
6.12.0 <= version < 6.12.3
6.13.0 <= version < 6.13.3
6.14.0 <= version < 6.14.2


Fixed Confluence Server and Confluence Data Center product versions:

* for 6.6.x, Confluence Server and Data Center 6.6.12 have been
released with a fix for these issues.
* for 6.12.x, Confluence Server and Data Center 6.12.3 have been
released with a fix for these issues.
* for 6.13.x, Confluence Server and Data Center 6.13.3 have been
released with a fix for these issues.
* for 6.14.x, Confluence Server and Data Center 6.14.2 have been
released with a fix for these issues.


Summary:
This advisory discloses critical severity security vulnerabilities. Versions of
Confluence Server and Data Center before 6.6.12 (the fixed version for 6.6.x),
from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version
6.13.0 before 6.13.3 (the fixed version for 6.13.x) and from version 6.14.0
before 6.14.2 (the fixed version for 6.14.x) are affected by these
vulnerabilities.



Customers who have upgraded Confluence to version 6.6.12 or 6.12.3 or
6.13.3 or 6.14.2 are not affected.

Customers who have downloaded and installed Confluence >= 6.6.0 but less
than 6.6.12 (the fixed version for 6.6.x) or who have downloaded and installed
Confluence >= 6.12.0 but less than 6.12.3 (the fixed version for 6.12.x)
or who have downloaded and installed Confluence >= 6.13.0 but less than
6.13.3 (the fixed version for 6.13.x) or who have downloaded and installed
Confluence >= 6.14.0 but less than 6.14.2 (the fixed version for 6.14.x)
please upgrade your Confluence installations immediately to fix these
vulnerabilities.



WebDAV vulnerability (CVE-2019-3395)

Severity:
Atlassian rates the severity level of this vulnerability as critical, according
to the scale published in our Atlassian severity levels. The scale allows us to
rank the severity as critical, high, moderate or low.
This is our assessment and you should evaluate its applicability to your own IT
environment.


Description:

A remote attacker is able to exploit a Server-Side Request Forgery (SSRF)
vulnerability via the WebDAV plugin to send arbitrary HTTP and WebDAV requests
from a Confluence Server or Data Center instance.
Versions of Confluence before version 6.6.7 (the fixed version for
6.6.x), from version 6.7.0 before 6.7.3 (the fixed version for 6.7.x), from
version 6.8.0 before 6.8.5 (the fixed version for 6.8.x) and from version 6.9.0
before 6.9.3 (the fixed version for 6.9.x) are affected by this vulnerability.
This issue can be tracked at: https://jira.atlassian.com/browse/CONFSERVER-57971
.

Remote code execution via Widget Connector macro (CVE-2019-3396)

Severity:
Atlassian rates the severity level of this vulnerability as critical, according
to the scale published in our Atlassian severity levels. The scale allows us to
rank the severity as critical, high, moderate or low.
This is our assessment and you should evaluate its applicability to your own IT
environment.


Description:

There was a server-side template injection vulnerability in Confluence
via Widget Connector. An attacker is able to exploit this issue to achieve path
traversal and remote code execution on systems that run a vulnerable version of
Confluence.
Versions of Confluence before version 6.6.12 (the fixed version for
6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from
version 6.13.0 before 6.13.3 (the fixed version for 6.13.x) and from version
6.14.0 before 6.14.2 (the fixed version for 6.14.x) are affected by this
vulnerability. This issue can be tracked at:
https://jira.atlassian.com/browse/CONFSERVER-57974 .



Fix:

To address these issues, we have released the following versions of
Confluence Server and Data Center containing a fix:

* version 6.6.12
* version 6.12.3
* version 6.13.3
* version 6.14.2

Remediation:

Upgrade Confluence Server and Data Center to version 6.14.2 or higher.

The vulnerabilities and fix versions are described above. If affected, you
should upgrade to the latest version immediately.

If you are running Confluence Server and or Data Center 6.6.x and cannot
upgrade to 6.14.2, upgrade to version 6.6.12.
If you are running Confluence Server and or Data Center 6.12.x and cannot
upgrade to 6.14.2, to version 6.12.3.
If you are running Confluence Server and or Data Center 6.13.x and cannot
upgrade to 6.14.2, upgrade to version 6.13.3.


For a full description of the latest version of Confluence Server and
Data Center, see the release notes found at
https://confluence.atlassian.com/display/DOC/Confluence+Release+Notes. You can
download the latest version of Confluence Server and Confluence Data Center
from the download centre found at
https://www.atlassian.com/software/confluence/download.



Support:
If you have questions or concerns regarding this advisory, please raise a
support request at https://support.atlassian.com/.


-----BEGIN PGP SIGNATURE-----

iQJLBAEBCgA1FiEEXh3qw5vbMx/VSutRJCCXorxSdqAFAlyYJv8XHHNlY3VyaXR5
QGF0bGFzc2lhbi5jb20ACgkQJCCXorxSdqCusg//TLxv04m9mKEWc0Ci6fMzP7HQ
JbZvsQ3AGae9NQ58VU3+wf/Ay+jIfyxniTqX8zivoKL8PUexwvlnyksJVVLScVwJ
dYErA1HSwpeUqmzFt8NXlwoEovXZeA6rWWBg0lrbt6JOeK64ZHAC2NMfOouoTfHk
YtCQLfao2HXF7NYp37T1lL8zhhkxVwAuTenWa13BPmi6PXBblUyyScA+Sol+cNy6
oqtKuyXlZGDbGznxpP8t8Hp9mPiSluPE8KGES0qap/zMA2ZimAdwBkWwmB4K3LMT
59fV2hCkfrWNGOdyYh7G9jgK9nhDpPrWrjJEh6uKidVZ/wKgCXCYVAhu+kfA1/uJ
uUs3NiWDcfnqFsrc6lWvpSvNR0ramLRoo7dDz4H9U+qBoX+mS0Fo49W74scj3LF0
vp4gp8V9ioHyCtOLlyHvIENCE75UkdA7oKZxfYvUdPleZx2e5ywBQDCytGX0hDmO
DP/gBgH4kP+cDBqVrJXErEHfn2Jzxj+L9Um6BKFe5pT12+MyONiitApqQksU6iC1
zhIc0ntYHGktfgqZT6/iQQeFY2rH+meonreTYAo0d2K84vAtkoteUrPNsTPWjSdI
FMqsj0wjKqvyyNzPMh/9yQEP451FgU0J3zb6JmFC/qN0bUtHRVEwBgrkprS9zFBn
8I/F9ne/9E5svmabflE=
=mCZI
-----END PGP SIGNATURE-----

Powered by blists - more mailing lists