lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
From: marklist at comcast.net (marklist@...cast.net)
Subject: A real-life story (no analogies) Was: Anti-MS drivel

> Bravo, Radule, bravo.
> 
> Your story started my Friday with weekend plans to finally scrap xp at
> home for my attempt at SuSE.
> Thank you in advance.
> 
> At least one changed user, 
> -Jeff Parker
> 

I too can vouch for what Radule experienced.  A year ago I bought a Sony 
Digital8 Camcorder, which shows up as a memory stick reader when plugged
into a USB port when in memory mode.  Had I read the instructions before
plugging it in, I would have read that the win2k OS drivers are not 
compatible with the camcorder.  After losing all of my first few pictures
when win2k corrupted the FAT on the memory stick, I went through the 
process of removing the driver manually and reinstalling the SonyUSB 
drivers that came with the camcorder.  It finally worked.

Plugging it in while running Suse 8.1 worked perfectly.

I received a little PNY Attache USB Flash disk as a present this last
Christmas, and plugging it in to my win2k box caused my CPU usage to peg
at 100%, and explorer was non-functional(trying to refresh the left pane
with my new drive letter).  Remembering that I had installed the sony
drivers, I went through the process of uninstalling the sony drivers to
try to restore the original win2k drivers.  I even removed all of the
.inf files from \winnt\inf.  Great, plug it back in and without prompting
me, it reloads the sony drivers from the folder \drivers\sonyusb where
I had installed them from before.

Back to step 1, renamed the sonyusb folder.  Finally got the original
OS drivers installed, and my new keychain worked.  I have strong fear
of plugging my camcorder back in now.

Plugging it in while running Suse 8.1 worked perfectly.

My question is: If the USB Mass Storage device is a "standard" interface,
why would the stock win2k drivers only work with certain models, creating
incompatibility with devices?  Apparently Matthew Dharm, who wrote (or at
least is taking credit for) the linux usb-storage driver has a clue where
MS is lacking.

The point here is, if you can run Windows on the desktop, you can run 
Linux on the desktop just as easily.  And in some cases much more easily.

Mark


Powered by blists - more mailing lists