lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
From: nion at gmx.net (Nico Golde)
Subject: FAT32 input > output = null?

Hallo chris,

* chris <chris@...con.org> [2004-04-09 13:38]:
> >i don't understand your problem.
> >i tried:
> >[nico@...de:~] $ ls -al test
> >-rw-r--r--    1 nico     users           6 2004-04-08 11:46 test
> >[nico@...de:~] $ test>test
> >[nico@...de:~] $ ls -al test
> >-rw-r--r--    1 nico     users           0 2004-04-08 11:47 test
> >
> >but it is not wondering because you put the output of the first command
> >in the file after the >. because you have not a real command and you
> >have no real output you overwrite the file with an empty output stream
> >and the file is 0 byte after it.
> >haven't i understand your problem correctly?
> >regards nico
> 
> I don't really have a problem.  The original poster tried this on a FAT32
> system and asked if it was normal behavior.  Another poster confirmed that
> this was the case with NTFS and I was merely doing the same for ext3.

ok sorry, i misunderstood.
regards nico
-- 
Nico Golde                | nico@...lde.de      | 310777820@ICQ | nion@....net
http://www.ngolde.de      | GnuPG Key: http://www.ngolde.de/gpg/nico_golde.gpg
Fingerprint               | FF46 E565 5CC1 E2E5 3F69  C739 1D87 E549 7364 7CFF 
vim -c   ":%s/^/WhfgTNabgureRIvzSUnpxreT-Tavba/|:%s/[R-T]/ /Ig|:normal ggVGg?"
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.grok.org.uk/pipermail/full-disclosure/attachments/20040409/5e4e067d/attachment.bin

Powered by blists - more mailing lists