lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date: Wed,  8 Aug 2012 18:21:10 +0000 (UTC)
From: security-news@...pal.org
To: security-news@...pal.org
Subject: [Security-news] SA-CONTRIB-2012-121 - Shorten
	URLs - Cross Site	Scripting (XSS)

View online: http://drupal.org/node/1719392

  * Advisory ID: DRUPAL-SA-CONTRIB-2012-121
  * Project: Shorten URLs [1] (third-party module)
  * Version: 6.x, 7.x
  * Date: 2012-August-8
  * Security risk: Moderately critical [2]
  * Exploitable from: Remote
  * Vulnerability: Cross Site Scripting

-------- DESCRIPTION  
---------------------------------------------------------

The Shorten URLs module provides an API to shorten URLs via many services
like bit.ly and TinyURL, as well as a block and a page that provide an
interface for easily shortening URLs.

.... Cross Site Scripting via report

The module doesn't sufficiently sanitize user input when displaying shortened
URLs.
This vulnerability is mitigated by several factors:

  * The Record Shortened URLs submodule must be installed
  * The Views module must /not/ be installed
  * An attacker must either have the "use Shorten URLs page" permission or
    access to the Shorten URLs block

CVE: Requested

.... Cross Site Scripting via Custom Services List

There is an additional XSS vulnerability where the module doesn't
sufficiently sanitize user input when displaying custom URL shortening
services.

This vulnerability is mitigated by the fact that the "Shorten URLs Custom
Services" submodule must be enabled and the attacker must have the
"administer Shorten URLs custom services" permission, which should not be
given to non-administrators.

CVE: Requested

-------- VERSIONS AFFECTED  
---------------------------------------------------

  * Shorten URLs 6.x-1.x versions prior to 6.x-1.13.
  * Shorten URLs 7.x-1.x versions prior to 7.x-1.2.

Drupal core is not affected. If you do not use the contributed Shorten URLs
[3] module, there is nothing you need to do.

-------- SOLUTION  
------------------------------------------------------------

Install the latest version:

  * If you use the Shorten URLs module for Drupal 6.x, upgrade to Shorten URLs
    6.x-1.13 [4]
  * If you use the Shorten URLs module for Drupal 7.x, upgrade to Shorten URLs
    7.x-1.2 [5]

Also see the Shorten URLs [6] project page.

-------- REPORTED BY  
---------------------------------------------------------

  * Zach Alexander [7]
  * Justin Klein Keane [8]

-------- FIXED BY  
------------------------------------------------------------

  * Isaac Sukin [9], the module maintainer
  * Zach Alexander [10]
  * Justin Klein Keane [11]

-------- COORDINATED BY  
------------------------------------------------------

  * Stella Power [12] of the Drupal Security Team
  * Greg Knaddison [13] of the Drupal Security Team

-------- CONTACT AND MORE INFORMATION  
----------------------------------------

The Drupal security team can be reached at security at drupal.org or via the
contact form at http://drupal.org/contact [14].

Learn more about the Drupal Security team and their policies [15], writing
secure code for Drupal [16], and securing your site [17].


[1] http://drupal.org/project/shorten
[2] http://drupal.org/security-team/risk-levels
[3] http://drupal.org/project/shorten
[4] https://drupal.org/node/1719306
[5] https://drupal.org/node/1719310
[6] http://drupal.org/project/shorten
[7] https://drupal.org/user/1972656
[8] https://drupal.org/user/302225
[9] https://drupal.org/user/201425
[10] https://drupal.org/user/1972656
[11] https://drupal.org/user/302225
[12] http://drupal.org/user/66894
[13] http://drupal.org/user/36762
[14] http://drupal.org/contact
[15] http://drupal.org/security-team
[16] http://drupal.org/writing-secure-code
[17] http://drupal.org/security/secure-configuration

_______________________________________________
Security-news mailing list
Security-news@...pal.org
Unsubscribe at http://lists.drupal.org/mailman/listinfo/security-news

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/

Powered by blists - more mailing lists