lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date: Wed, 18 Sep 2013 20:26:58 +0000 (UTC)
From: security-news@...pal.org
To: security-news@...pal.org
Subject: [Security-news] SA-CONTRIB-2013-077 - Google Site
	Search - Cross	Site Scripting (XSS)

View online: https://drupal.org/node/2092395

  * Advisory ID: DRUPAL-SA-CONTRIB-2013-077
  * Project: Google Site Search [1] (third-party module)
  * Version: 6.x, 7.x
  * Date: 2013-September-18
  * Security risk: Less critical [2]
  * Exploitable from: Remote
  * Vulnerability: Cross Site Scripting

-------- DESCRIPTION  
---------------------------------------------------------

This module enables you to use the Google API to search one or more sites and
show the result in your Drupal site, with your custom styling.

The module doesn't sufficiently sanitize the data retrieved from the Google
API.

This vulnerability is mitigated by the fact that an attack must come from the
API which requires either compromising Google or spoofing DNS.


-------- CVE IDENTIFIER(S) ISSUED  
--------------------------------------------

  * /A CVE identifier [3] will be requested, and added upon issuance, in
    accordance with Drupal Security Team processes./

-------- VERSIONS AFFECTED  
---------------------------------------------------

  * Google Site Search 6.x-1.x versions before 6.x-1.4.
  * Google Site Search 7.x-1.x versions before 7.x-1.10.

Drupal core is not affected. If you do not use the contributed Google Site
Search [4] module, there is nothing you need to do.

-------- SOLUTION  
------------------------------------------------------------

Install the latest version:

  * If you use the Google Site Search module for Drupal 6.x, upgrade to
    6.x-1.4 [5]
  * If you use the Google Site Search module for Drupal 7.x, upgrade to
    7.x-1.10 [6]

Also see the Google Site Search [7] project page.

-------- REPORTED BY  
---------------------------------------------------------

  * Philip Hornig [8]

-------- FIXED BY  
------------------------------------------------------------

  * Dhavyd Vanderlei [9] the module maintainer

-------- COORDINATED BY  
------------------------------------------------------

  * pwolanin [10] of the Drupal Security Team

-------- CONTACT AND MORE INFORMATION  
----------------------------------------

The Drupal security team can be reached at security at drupal.org or via the
contact form at http://drupal.org/contact [11].

Learn more about the Drupal Security team and their policies [12], writing
secure code for Drupal [13], and securing your site [14].


[1] http://drupal.org/project/gss
[2] http://drupal.org/security-team/risk-levels
[3] http://cve.mitre.org/
[4] http://drupal.org/project/gss
[5] https://drupal.org/node/2091745
[6] https://drupal.org/node/2091753
[7] http://drupal.org/project/gss
[8] http://drupal.org/user/611674
[9] http://drupal.org/user/1483950
[10] http://drupal.org/user/49851
[11] http://drupal.org/contact
[12] http://drupal.org/security-team
[13] http://drupal.org/writing-secure-code
[14] http://drupal.org/security/secure-configuration

_______________________________________________
Security-news mailing list
Security-news@...pal.org
Unsubscribe at http://lists.drupal.org/mailman/listinfo/security-news

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/

Powered by blists - more mailing lists