lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [day] [month] [year] [list]
Date: Mon, 14 Jul 2014 12:58:17 +0200
From: Egidio Romano <research@...mainsecurity.com>
To: bugtraq@...urityfocus.com, fulldisclosure@...lists.org
Subject: [FD] [KIS-2014-08] OpenCart <= 1.5.6.4 (cart.php) PHP Object
 Injection Vulnerability

-----------------------------------------------------------------
OpenCart <= 1.5.6.4 (cart.php) PHP Object Injection Vulnerability
-----------------------------------------------------------------


[-] Software Link:

http://www.opencart.com/


[-] Affected Versions:

Version 1.5.6.4 and prior versions.


[-] Vulnerability Description:

The vulnerable code is located in the "Cart::getProducts()" method defined in /system/library/cart.php:

23.		foreach ($this->session->data['cart'] as $key => $quantity) {
24.			$product = explode(':', $key);
25.			$product_id = $product[0];
26.			$stock = true;
27.	
28.			// Options
29.			if (!empty($product[1])) {
30.				$options = unserialize(base64_decode($product[1]));
31.			} else {
32.				$options = array();
33.			}

The vulnerability exists because this method uses the "unserialize()" function with the key values of the
array stored into the "data['cart']" session variable without a proper validation.  Such values might be
manipulated by an unauthenticated attacker via the $_POST['quantity'] parameter during an "update" request.
This can be exploited to inject arbitrary PHP objects into the application scope, and could allow an attacker
to conduct Server-Side Request Forgery (SSRF) attacks by abusing the destructor method of the "DBMySQLi"
class and possibly other attacks leveraging magic methods of classes defined in third-party extensions.

NOTE: if OpenCart is running on PHP before version 5.3.23 or 5.4.13 this vulnerability
could also be exploited to carry out XML External Entity (XXE) attacks, which in turn
might allow arbitrary command execution if the PHP "expect" extension is installed.


[-] Solution:

Update to version 1.5.6.5 when will be released or apply this patch: http://git.io/F3dGoA


[-] Disclosure Timeline:

[02/06/2014] - First attempt to contact the vendor
[04/06/2014] - Issue reported to http://git.io/uOsKfA
[06/06/2014] - CVE number requested
[06/06/2014] - CVE number assigned
[25/06/2014] - Vendor contacted again asking when will be released a fixed version
[25/06/2014] - Vendor replied there's no need to alert its users because the vulnerability is very weak
[14/07/2014] - Public disclosure


[-] CVE Reference:

The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the name CVE-2014-3990 to this vulnerability.


[-] Credits:

Vulnerability discovered by Egidio Romano.


[-] Original Advisory:

http://karmainsecurity.com/KIS-2014-08

_______________________________________________
Sent through the Full Disclosure mailing list
http://nmap.org/mailman/listinfo/fulldisclosure
Web Archives & RSS: http://seclists.org/fulldisclosure/

Powered by blists - more mailing lists