lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date: Mon, 27 Apr 2020 17:41:27 +0200
From: Balázs Hambalkó <hambalko.balazs@...il.com>
To: fulldisclosure@...lists.org
Subject: [FD] Gigamon - GigaVUE 0day

Hi,

An issue was discovered in Gigamon GigaVUE 5.5.01.11.
The upload functionality allows an authenticated user to change the
filename value (in the POST method) from the original filename
to achieve directory traversal via a ../ sequence and, for example,
obtain a complete directory listing of the machine.

------------------------------------------

[Additional Information]
This vulnerability aid the attacker in discovering the whole file
system in the underlying host system - including identifying the
writeable and read-only file systems.

The authenticated user needs to use the upload functionality. The POST
HTTP verb is being used which needs to be intercepted, and modified
(the "filename" parameter must be manipulated in the POST body
section)

These vulnerabilities were reported to the vendor. They said this
version will be decommissioned in 2023 and they decided not to provide
technical support anymore. In other words, they will not fix any IT
Security Issues which have lower than critical risk. This
version is in production in enterprise environments, and will be
available until end of 2023, so the impact is real.

------------------------------------------

[Vulnerability Type]
Directory Traversal

------------------------------------------

[Vendor of Product]
Gigamon

------------------------------------------

[Affected Product Code Base]
GigaVUE - 5.5.01.11

------------------------------------------

[Affected Component]
Upload functionality

------------------------------------------

[Attack Type]
Remote

------------------------------------------

[Impact Information Disclosure]
true

------------------------------------------

[Attack Vectors]
The authenticated user needs to use the upload functionality. The POST
HTTP verb is being used which needs to be intercepted, and modified
(the "filename" parameter must be manipulated in the POST body
section)

------------------------------------------

[Reference]https://www.gigamon.com/products/access-traffic/physical-nodes.html

------------------------------------------

[Has vendor confirmed or acknowledged the vulnerability?]
true

------------------------------------------

[Discoverer]
Balazs Hambalko, IT Security Consultant

Use CVE-2020-12251.



An issue was discovered in Gigamon GigaVUE 5.5.01.11. The upload
functionality allows an arbitrary file upload for an authenticated
user. If an executable file is uploaded into the www-root directory,
then it could yield remote code execution via the filename parameter.

------------------------------------------

[Additional Information]
These vulnerabilities were reported to the vendor. They said this
version will be decommissioned in 2023 and they decided not to provide
technical support anymore. In other words, they will not fix any IT
Security Issues which have lower than critical risk. This
version is in production in enterprise environments, and will be
available until end of 2023, so the impact is real.

------------------------------------------

[Vulnerability Type]
Insecure Permissions

------------------------------------------

[Vendor of Product]
Gigamon

------------------------------------------

[Affected Product Code Base]
GigaVUE - 5.5.01.11

------------------------------------------

[Affected Component]
Upload functionality

------------------------------------------

[Attack Type]
Remote

------------------------------------------

[Impact Code execution]
true

------------------------------------------

[Attack Vectors]
The authenticated user needs to use the upload functionality. The POST
HTTP verb is being used which needs to be intercepted, and modified
(the "filename" parameter must be manipulated in the POST body
section)

------------------------------------------

[Reference]https://www.gigamon.com/products/access-traffic/physical-nodes.html

------------------------------------------

[Has vendor confirmed or acknowledged the vulnerability?]
true

------------------------------------------

[Discoverer]
Balazs Hambalko, IT Security Consultant


Use CVE-2020-12252.

_______________________________________________
Sent through the Full Disclosure mailing list
https://nmap.org/mailman/listinfo/fulldisclosure
Web Archives & RSS: http://seclists.org/fulldisclosure/

Powered by blists - more mailing lists