lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 5 Jun 2007 10:46:57 -0500
From:	"Jose R. Santos" <jrs@...ibm.com>
To:	Laurent Vivier <Laurent.Vivier@...l.net>
Cc:	Dave Kleikamp <shaggy@...ux.vnet.ibm.com>, cmm@...ibm.com,
	Andreas Dilger <adilger@...sterfs.com>,
	linux-ext4 <linux-ext4@...r.kernel.org>
Subject: Re: [RFC][PATCH] Set JBD2_FEATURE_INCOMPAT_64BIT on filesystems
 larger than 32-bit blocks (take 2).

On Tue, 05 Jun 2007 16:03:44 +0200
Laurent Vivier <Laurent.Vivier@...l.net> wrote:
> Jose R. Santos wrote:
> > Hi Laurent,
> > 
> > In this particular case though, the value of s_blocks_count_hi should not be
> > uses on its own.  The correct way would be to use ext4_blocks_count() which
> > already does the endian conversion.  If you think the code could confuse
> > people as to how to access the data in s_blocks_count_hi, wouldn't hiding it
> > through the use of a macro make more sense than doing an unnecessary endian
> > conversion?
> > 
> 
> Yes, I think the code could confuse people, but I don't think defining "Yet
> Another Macro" is a good choice (IMHO).
> 
> I think we can resolve this (non-)issue by two ways:
> - using le32_to_cpu() (but I agree it does an unnecessary endian conversion on
> big-endian systems)

I just think that adding extra instructions for the sake of slightly
better code readability is wrong, especially when the value
s_blocks_count_hi should not be used on its own.

> - put a comment on the line (but are we allowed to put comments in kernel source
> code... ;-) )

One advantage of a macro here is that we would make the code more
explicit and should be able to eliminate the need for those 4 lines of
comments that this patch adds.

> Regards
> Laurent


-JRS
-
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists