[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <873ama2i51.fsf@frosties.localdomain>
Date: Wed, 16 Jul 2008 13:16:58 +0200
From: Goswin von Brederlow <goswin-v-b@....de>
To: "Jose R. Santos" <jrs@...ibm.com>
Cc: "Theodore Ts'o" <tytso@....edu>, linux-ext4@...r.kernel.org
Subject: Re: [PATCH 01/15][e2fsprogs] libext2fs: Add 64-bit support to the undo manager
"Jose R. Santos" <jrs@...ibm.com> writes:
> From: Jose R. Santos <jrs@...ibm.com>
>
> libext2fs: Add 64-bit support to the undo manager
>
> Signed-off-by: "Theodore Ts'o" <tytso@....edu>
> --
>
> lib/ext2fs/undo_io.c | 55 +++++++++++++++++++++++++++++++++++++++++---------
> 1 files changed, 45 insertions(+), 10 deletions(-)
>
> diff --git a/lib/ext2fs/undo_io.c b/lib/ext2fs/undo_io.c
> index 827c038..7661b83 100644
> --- a/lib/ext2fs/undo_io.c
> +++ b/lib/ext2fs/undo_io.c
> @@ -73,6 +73,10 @@ struct undo_private_data {
> static errcode_t undo_open(const char *name, int flags, io_channel *channel);
> static errcode_t undo_close(io_channel channel);
> static errcode_t undo_set_blksize(io_channel channel, int blksize);
> +static errcode_t undo_read_blk64(io_channel channel, unsigned long long block,
> + int count, void *data);
Why not this?
+static errcode_t undo_read_blk64(io_channel channel, blk64_t block,
+ int count, void *data);
libext2fs specifically has blk_t and blk64_t types to represent a
block. Why not use them? It is less to type and easier to read.
MfG
Goswin
--
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists