lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 2 Nov 2008 18:01:35 -0500
From:	Theodore Tso <tytso@....edu>
To:	Fran├žois Valenduc 
	<francois.valenduc@...ablenet.be>
Cc:	Graham Murray <graham@...rray.org.uk>, linux-ext4@...r.kernel.org
Subject: Re: Wrong calculation of space remaining on a 32 bit system.

On Sun, Nov 02, 2008 at 11:24:31PM +0100, Fran├žois Valenduc wrote:
> 
> How can I know if I ran out of inodes ? I already tried 128 and 256
> inode sizes but the problem occurs in both cases. 

By using the command "df -i".  It will list the number of inodes that
are in use.

The tuning parameters for mke2fs is -i (the inode ratio), or -N
(number of inodes).  The number of inodes is normally calculated as a
ratio to the disk size.  The normal inode ratio is 16384, which allows
for an average inode size of 16k.  If you have a huge number of small
files, or small directories, or a huge number of symbolic links or
device nodes in the filesystem, you can run out of inodes.  You can
change this either by specifying a a smaller inode ratio, or by
explicitly specifying the number of inodes you want created using the
-N option.

> As I said in my bug
> report, I found a patch dated from november 2007 which seems to adress
> the problem (see
> http://osdir.com/ml/file-systems.ext4/2007-11/msg00200.htm).  Off course,
> I can't apply it any more now.

You can't apply it because it's already been applied; it's been in
mainline for quite a while.

>  But it seems this kind of problem still
> exists. I have no problem to use ext4 on a 64 bit systems with logical
> volumes having approximately the same size.

That seems very strange.  Maybe you have a different version of
mke2fs, or a different mke2fs.conf file?  (The default inode size can
be controlled by the mke2fs.conf file.)

Can you send the output of "dumpe2fs -h" on a filesystem where you are
having this problem, and on a filesystem from the 64-bit system where
it is working correctly?

					- Ted
--
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists