[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1275119968.2668.7.camel@localhost.localdomain>
Date: Sat, 29 May 2010 10:59:28 +0300
From: Artem Bityutskiy <dedekind1@...il.com>
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: Al Viro <viro@...IV.linux.org.uk>,
LKML <linux-kernel@...r.kernel.org>,
Jens Axboe <jens.axboe@...cle.com>,
linux-fsdevel@...r.kernel.org,
Roman Zippel <zippel@...ux-m68k.org>,
"Tigran A. Aivazian" <tigran@...azian.fsnet.co.uk>,
Chris Mason <chris.mason@...cle.com>,
Boaz Harrosh <bharrosh@...asas.com>,
linux-ext4@...r.kernel.org, Theodore Ts'o <tytso@....edu>,
OGAWA Hirofumi <hirofumi@...l.parknet.co.jp>,
David Woodhouse <dwmw2@...radead.org>,
reiserfs-devel@...r.kernel.org, Jan Kara <jack@...e.cz>,
Evgeniy Dushistov <dushistov@...l.ru>
Subject: Re: [PATCHv4 01/17] VFS: introduce helpers for the s_dirty flag
On Fri, 2010-05-28 at 13:23 -0700, Andrew Morton wrote:
> > +static inline void mark_sb_dirty(struct super_block *sb)
> > +{
> > + sb->s_dirt = 1;
> > +}
> > +static inline void mark_sb_clean(struct super_block *sb)
> > +{
> > + sb->s_dirt = 0;
> > +}
> > +static inline int is_sb_dirty(struct super_block *sb)
> > +{
> > + return sb->s_dirt;
> > +}
>
> A more conventional and superior naming scheme is
> subsystemid_specific_function_identifier(). eg, bio_add_page() instead
> of add_page_to_bio().
>
> So these want to be sb_mark_dirty(), etc.
>
> Being very old code written by very yound people, the VFS kinda ignores
> that convention, but it doesn't hurt to use it for new code.
>
> Feel free to ignore me if that's too much of a PITA ;)
Sure I'll re-name them, thanks!
--
Best Regards,
Artem Bityutskiy (Артём Битюцкий)
--
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists