lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 30 Apr 2012 09:17:52 -0500
From:	Eric Sandeen <>
To:	Matthew Wilcox <>
CC:	Eric Sandeen <>,
	"" <>,
	ext4 development <>,
	Andreas Dilger <>,
	Bernd Schubert <>
Subject: Re: [PATCH] vfs: allow custom EOF in generic_file_llseek code

On 4/28/12 1:33 PM, Matthew Wilcox wrote:
> On Fri, Apr 27, 2012 at 11:21:04AM -0500, Eric Sandeen wrote:
>> As far as I know, this does not fix any bugs - nfs in the kernel
>> doesn't use SEEK_END, and I don't know of any user who does.  But
>> some ext4 folks seem keen on doing the right thing here, and I can't
>> really argue.
> I like it.  In particular it removes a lot of calls to i_size_read() which
> may have some nice benefits on 32-bit systems.  
> However, there is only one call to generic_file_llseek_size() in the
> kernel (and it's in ext4!)  I would suggest simply changing the prototype
> of generic_file_llseek_size ... or if you insist, just renaming it to
> generic_file_llseek_size_eof().

Ok, if both users are only in ext* you're right, probably no need to have
both variants with 2 kinds of special sauce.  Is it cool to change the
prototype of the existing function, or should I rename it?  I guess since
it'll properly break any current users in obvious ways, I could just
add a new argument to the _size() variant.  I'll send a V2.


To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to
More majordomo info at

Powered by blists - more mailing lists