lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 30 Jul 2012 20:00:49 +0000 (UTC)
From:	bugzilla-daemon@...zilla.kernel.org
To:	linux-ext4@...r.kernel.org
Subject: [Bug 42895] jbd2 makes all system unresponsive

https://bugzilla.kernel.org/show_bug.cgi?id=42895


Nicolas Ecarnot <nicolas.ecarnot@...e.fr> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |nicolas.ecarnot@...e.fr




--- Comment #21 from Nicolas Ecarnot <nicolas.ecarnot@...e.fr>  2012-07-30 20:00:49 ---
Hi,

I eventually found the thread I was looking for and I feel the need to testify
what I'm experiencing.

I have some IT skills but here I won't go deep into details.
I'm a very conservative user and my setups and software usage are *very*
stable. The set of apps I'm using month after month do not change, and I'm not
the kind of people that installs a new app or plugin every day.
That allows me to observe the improvement or flows of system upgrades as time
goes by.

I'm using Xubuntu Precise 12.04 on a 64 bits cpu :
| root@...xx:~# uname -a
| Linux xxxxx 3.2.0-27-generic #43-Ubuntu SMP Fri Jul 6 14:25:57 UTC 2012
x86_64 x86_64 x86_64 GNU/Linux
and I'm running the common almost daily/weekly upgrades.

Since say one week, every action I do leads to a massive disk I/O activity that
freezes my whole system (GUI or via ssh, same punishment). The action I'm
talking about are very complex : open a new tab in firefox, launch xterm,
create a new mail, close xterm, click to expand the menu (!)...
To post the message you are reading, I had to create an account.
Clicking on the "Send" button to submit my form took a solid two minutes to
complete. This makes no sense.

Read my lips : my setup was very simple and efficient, and all of a sudden, it
became unusable.

As other tried it, I tried to play with iotop, htop and so on. I tried to blame
my home partition in btrfs, but I'm using it with no issue for months. I tried
to blame some specific apps, and thought I found it when disabling a
iphone-automount related bin, but issue arose since.
I discovered the recent use of cgroups, but I've no clue whether this deserves
blaming. From times to times, iotop is showing my jbd2 activity, of btrfs
caching, but this is not related to 100% of freeze events.
Googling showed me this was not an ubuntu-specific issue.
Experts will have to decide if this is a filesystem-specific issue...

This bug appears to me quite serious and deserves attention. I'm very surprised
such a thing isn't more widely spread and then fixed.

-- 
Configure bugmail: https://bugzilla.kernel.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching the assignee of the bug.
--
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists