lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 27 Nov 2012 09:20:47 +0800
From:	Ryan Wang <openspace.wang@...il.com>
To:	"Theodore Ts'o" <tytso@....edu>
Cc:	Lukáš Czerner <lczerner@...hat.com>,
	linux-ext4@...r.kernel.org, xfs@....sgi.com
Subject: Re: How to run xfstests against multipath disks on SuSE?

2012/11/26 Theodore Ts'o <tytso@....edu>:
> On Mon, Nov 26, 2012 at 02:43:40PM +0100, Lukáš Czerner wrote:
>> > The I checked the script common.rc, and found that it uses
>> > df to determine the filesystem type and it uses the realpath
>> > "/dev/dm-0" instead of "/dev/mapper/mpatha", while df always
>> > shows "devtmpfs" instead of "ext4" for /dev/dm-0.
>> >
>> > I run "mount" and found that devtmpfs is mount on /dev/ on opensuse
>> > ***by default***. Even though  I run "mount -t btrfs /dev/dm-0 /somedir",
>> > df still showed devtmpfs.
>> >
>> > Any ideas to kick off the xfstests?
>
> At least with the df which ships with Debian Testing, df will display
> the file system in use if it matches the device name which is
> /etc/mtab.  It looks the issue is that mount is canonicalizing the
> device name to be the human friendly version:
>
> # ls -l /dev/mapper/closure-bigscratch
> 0 lrwxrwxrwx 1 root root 7 Nov 16 15:15 /dev/mapper/closure-bigscratch -> ../dm-7
> <tytso.root@...sure> {/home/tytso/bin}, level 2
> # mount /dev/dm-7 /u2
> # df /u2
> Filesystem                     1K-blocks   Used Available Use% Mounted on
> /dev/mapper/closure-bigscratch  52403200 224772  52178428   1% /u2
> # grep /u2 /etc/mtab
> /dev/mapper/closure-bigscratch /u2 xfs rw,relatime,attr2,inode64,noquota 0 0
>
> So the simplest solution is to just use /dev/mapper/mpatha instead of
> insisting on using /dev/dm-0.  That's what I do....

In xfstests/common.rc, it will use realpath to obtain /dev/dm-0, even if you
specified /dev/mapper/mpatha.
My problem is in SuSE, the devtmpfs is mounted on /dev by default, seems
used by udev. And df reports devtmpfs on /dev/dm-0, instead of ext4.

>
>                                                 - Ted
>
--
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists