lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Fri, 11 Sep 2015 08:39:04 -0400
From:	Chris Hunter <chris.hunter@...e.edu>
To:	linux-ext4@...r.kernel.org
Subject: Re: e2fsck discrepancy with debugfs stat ?

To follow-up on my own question,

The "dry-run" e2fsck does not replay the ext journal. So my discrepancy, 
e2fsck reports a unused/deleted inode bug debugfs is able to access the 
inode & file data, could be due to uncommitted journal transactions.

regards,
chris hunter
chris.hunter@...e.edu

On 09/10/2015 11:03 PM, Chris Hunter wrote:
> Hi,
> Are there scenarios where e2fsck will report a deleted/unused inode but
> debugfs is able to read the inode structure ?
>
> Some details:
> I am using lustre version of e2fsprogs (1.42.12.wc1). When I run e2fsck
> in nofix/dry-run mode on a blockdev, I receive errors about unused inodes.
> eg)
>  > $ e2fsck -nfv <DEV>
>> e2fsck 1.42.12.wc1 (15-Sep-2014)
>> Warning: skipping journal recovery because doing a read-only
>> filesystem check.
>> Pass 1: Checking inodes, blocks, and sizes
>> Pass 2: Checking directory structure
>> Entry '131249395' in /O/0/d19 (118843419) has deleted/unused inode
>> 5671802.  Clear? no
> etc...
>
> However when I run command debugfs -c -R "stat /O/0/d19/131249395"
> <DEV>, I can retrieve inode contents. Further debugfs "dump" will
> successfully pull the contents (980 bytes) of the file entry.
>
> thanks,
> chris hunter
> chris.hunter@...e.edu
--
To unsubscribe from this list: send the line "unsubscribe linux-ext4" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists