[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20171016074504.GA7316@infradead.org>
Date: Mon, 16 Oct 2017 00:45:04 -0700
From: "hch@...radead.org" <hch@...radead.org>
To: "Williams, Dan J" <dan.j.williams@...el.com>
Cc: "hch@...radead.org" <hch@...radead.org>,
"jack@...e.cz" <jack@...e.cz>,
"linux-xfs@...r.kernel.org" <linux-xfs@...r.kernel.org>,
"darrick.wong@...cle.com" <darrick.wong@...cle.com>,
"akpm@...ux-foundation.org" <akpm@...ux-foundation.org>,
"luto@...nel.org" <luto@...nel.org>,
"linux-fsdevel@...r.kernel.org" <linux-fsdevel@...r.kernel.org>,
"ross.zwisler@...ux.intel.com" <ross.zwisler@...ux.intel.com>,
"linux-ext4@...r.kernel.org" <linux-ext4@...r.kernel.org>,
"tytso@....edu" <tytso@....edu>, "arnd@...db.de" <arnd@...db.de>
Subject: Re: [PATCH 01/19] mm: introduce MAP_SHARED_VALIDATE, a mechanism to
safely define new mmap flags
> How about the following incremental update? It allows ->mmap_validate()
> to be used as a full replacement for ->mmap() and it limits the error
> code freedom to a centralized mmap_status_errno() routine:
Nah - my earlier comment was simply misinformed because I didn't
read the whole patch and the _validate name mislead me.
So I think the current calling conventions are ok, I'd just like a
better name (mmap_flags maybe?) and avoid the need the file system
also has to implement ->mmap.
Powered by blists - more mailing lists