[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20171114055924.GA15810@infradead.org>
Date: Mon, 13 Nov 2017 21:59:24 -0800
From: Christoph Hellwig <hch@...radead.org>
To: Dan Williams <dan.j.williams@...el.com>
Cc: linux-nvdimm@...ts.01.org, Jan Kara <jack@...e.cz>,
"Darrick J. Wong" <darrick.wong@...cle.com>,
Dave Chinner <david@...morbit.com>, linux-xfs@...r.kernel.org,
linux-fsdevel@...r.kernel.org, linux-ext4@...r.kernel.org,
Christoph Hellwig <hch@....de>
Subject: Re: [PATCH] fs, dax: unify IOMAP_F_DIRTY read vs write handling
policy in the dax core
> - if ((flags & IOMAP_WRITE) && xfs_ipincount(ip) &&
> - (ip->i_itemp->ili_fsync_fields & ~XFS_ILOG_TIMESTAMP))
> - iomap->flags |= IOMAP_F_DIRTY;
> + if (xfs_ipincount(ip))
> + if (ip->i_itemp->ili_fsync_fields & ~XFS_ILOG_TIMESTAMP)
> + iomap->flags |= IOMAP_F_DIRTY;
Please don't split up the conditional and make it harder to read.
With that fixed up this looks fine to me:
Reviewed-by: Christoph Hellwig <hch@....de>
Powered by blists - more mailing lists