lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date:   Fri, 23 Nov 2018 16:25:06 +0100
From:   Jean-Christophe Guillain <jcguillain@...uans.com>
To:     <darrick.wong@...cle.com>
Cc:     <linux-ext4@...r.kernel.org>
Subject: Re: Metadata_csum is still enabled after trying to disable it.


​​​----- On Nov 22, 2018, at 4:01 AM, Darrick J. Wong darrick.wong@...cle.com wrote:
>> * I check : metadata checksum looks like disabled
>>     root@...t# tune2fs -l /dev/my_vol tune2fs 1.43.4 (31-Jan-2017)
>>     Filesystem volume name:   <none>
>>     [...]
>>     Journal backup:           inode blocks
>> 
>> * I change filesystem UUID : It looks like metada checksum still is enabled
>>     root@...t# tune2fs -U random /dev/my_vol
>>     tune2fs 1.43.4 (31-Jan-2017)
>>     Setting UUID on a checksummed filesystem could take some time.
>>     Proceed anyway (or wait 5 seconds) ? (y,N) y
>> 
>> Is it a bug ?
> 
> Yes.

Should I open a bug in bugzilla ?

> 
>> How can I actually disable this parameter ?
> 
> I think you have to turn off the metadata_csum_seed feature, but tbh
> tune2fs really shouldn't pester about !metadata_csum,metadata_csum_seed
> filesystems...
> 

I actually tried that (!metadata_csum,!metadata_csum_seed) : tune2fs has still the same behaviour.
How does it detect that the filesystem is (it shouldn't be anymore), or was checksummed ?

> --D
> 
>> Best regards,
>> jC Guillain
>> 
>> 



-- IMPORTANT NOTICE: 

The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

Powered by blists - more mailing lists