[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <1413703615.61223613.1547045659656.JavaMail.zimbra@redhat.com>
Date: Wed, 9 Jan 2019 09:54:19 -0500 (EST)
From: Pankaj Gupta <pagupta@...hat.com>
To: Jan Kara <jack@...e.cz>
Cc: linux-kernel@...r.kernel.org, kvm@...r.kernel.org,
qemu-devel@...gnu.org, linux-nvdimm@...1.01.org,
linux-fsdevel@...r.kernel.org,
virtualization@...ts.linux-foundation.org,
linux-acpi@...r.kernel.org, linux-ext4@...r.kernel.org,
linux-xfs@...r.kernel.org, stefanha@...hat.com,
dan j williams <dan.j.williams@...el.com>, riel@...riel.com,
nilal@...hat.com, kwolf@...hat.com, pbonzini@...hat.com,
zwisler@...nel.org, vishal l verma <vishal.l.verma@...el.com>,
dave jiang <dave.jiang@...el.com>, david@...hat.com,
jmoyer@...hat.com,
xiaoguangrong eric <xiaoguangrong.eric@...il.com>,
hch@...radead.org, mst@...hat.com, jasowang@...hat.com,
lcapitulino@...hat.com, imammedo@...hat.com, eblake@...hat.com,
willy@...radead.org, tytso@....edu,
adilger kernel <adilger.kernel@...ger.ca>,
darrick wong <darrick.wong@...cle.com>, rjw@...ysocki.net
Subject: Re: [PATCH v3 4/5] ext4: disable map_sync for virtio pmem
>
> On Wed 09-01-19 19:26:05, Pankaj Gupta wrote:
> > Virtio pmem provides asynchronous host page cache flush
> > mechanism. We don't support 'MAP_SYNC' with virtio pmem
> > and ext4.
> >
> > Signed-off-by: Pankaj Gupta <pagupta@...hat.com>
> ...
> > @@ -371,6 +373,13 @@ static int ext4_file_mmap(struct file *file, struct
> > vm_area_struct *vma)
> > if (!IS_DAX(file_inode(file)) && (vma->vm_flags & VM_SYNC))
> > return -EOPNOTSUPP;
> >
> > + /* We don't support synchronous mappings with guest direct access
> > + * and virtio based host page cache flush mechanism.
> > + */
> > + if (IS_DAX(file_inode(file)) && virtio_pmem_host_cache_enabled(dax_dev)
> > + && (vma->vm_flags & VM_SYNC))
> > + return -EOPNOTSUPP;
> > +
>
> Shouldn't there rather be some generic way of doing this? Having
> virtio_pmem_host_cache_enabled() check in filesystem code just looks like
> filesystem sniffing into details is should not care about... Maybe just
> naming this (or having a wrapper) dax_dev_map_sync_supported()?
Thanks for the feedback.
Just wanted to avoid 'dax' in function name just to differentiate this with real dax.
But yes can add a wrapper: dax_dev_map_sync_supported()
Thanks,
Pankaj
Powered by blists - more mailing lists