lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 21 Jan 2019 16:37:12 +0800
From:   Ming Lei <>
To:     Christoph Hellwig <>
Cc:     Jens Axboe <>,,,,
        Theodore Ts'o <>, Omar Sandoval <>,
        Sagi Grimberg <>,
        Dave Chinner <>,
        Kent Overstreet <>,
        Mike Snitzer <>,,
        Alexander Viro <>,,,
        David Sterba <>,,
        "Darrick J . Wong" <>,, Gao Xiang <>,, Coly Li <>,, Boaz Harrosh <>,
        Bob Peterson <>,
Subject: Re: [PATCH V14 00/18] block: support multi-page bvec

On Mon, Jan 21, 2019 at 09:22:46AM +0100, Christoph Hellwig wrote:
> On Mon, Jan 21, 2019 at 04:17:47PM +0800, Ming Lei wrote:
> > V14:
> > 	- drop patch(patch 4 in V13) for renaming bvec helpers, as suggested by Jens
> > 	- use mp_bvec_* as multi-page bvec helper name
> WTF?  Where is this coming from?  mp is just a nightmare of a name,
> and I also didn't see any comments like that.

You should see the recent discussion in which Jens doesn't agree on
renaming bvec helper name, so the previous patch of 'block: rename bvec helpers'
has to be dropped, and we have to find a new name for multi-page bvec

Jens mentioned we can do the rename in next release after the whole
patchset is merged first, then I think mp_bvec_* should be fine since
its life time is short.

Or do you other suggestion?


Powered by blists - more mailing lists