lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 11 Jun 2019 15:28:00 -0600
From:   Andreas Dilger <adilger@...ger.ca>
To:     Andrew Morton <akpm@...ux-foundation.org>
Cc:     Shyam Saini <shyam.saini@...rulasolutions.com>,
        kernel-hardening@...ts.openwall.com, linux-kernel@...r.kernel.org,
        keescook@...omium.org, linux-arm-kernel@...ts.infradead.org,
        linux-mips@...r.kernel.org, intel-gvt-dev@...ts.freedesktop.org,
        intel-gfx@...ts.freedesktop.org, dri-devel@...ts.freedesktop.org,
        netdev@...r.kernel.org, linux-ext4 <linux-ext4@...r.kernel.org>,
        devel@...ts.orangefs.org, linux-mm@...ck.org,
        linux-sctp@...r.kernel.org, bpf@...r.kernel.org,
        kvm@...r.kernel.org, mayhs11saini@...il.com,
        Alexey Dobriyan <adobriyan@...il.com>
Subject: Re: [PATCH V2] include: linux: Regularise the use of FIELD_SIZEOF
 macro

On Jun 11, 2019, at 3:09 PM, Andrew Morton <akpm@...ux-foundation.org> wrote:
> 
> On Tue, 11 Jun 2019 15:00:10 -0600 Andreas Dilger <adilger@...ger.ca> wrote:
> 
>>>> to FIELD_SIZEOF
>>> 
>>> As Alexey has pointed out, C structs and unions don't have fields -
>>> they have members.  So this is an opportunity to switch everything to
>>> a new member_sizeof().
>>> 
>>> What do people think of that and how does this impact the patch footprint?
>> 
>> I did a check, and FIELD_SIZEOF() is used about 350x, while sizeof_field()
>> is about 30x, and SIZEOF_FIELD() is only about 5x.
> 
> Erk.  Sorry, I should have grepped.
> 
>> That said, I'm much more in favour of "sizeof_field()" or "sizeof_member()"
>> than FIELD_SIZEOF().  Not only does that better match "offsetof()", with
>> which it is closely related, but is also closer to the original "sizeof()".
>> 
>> Since this is a rather trivial change, it can be split into a number of
>> patches to get approval/landing via subsystem maintainers, and there is no
>> huge urgency to remove the original macros until the users are gone.  It
>> would make sense to remove SIZEOF_FIELD() and sizeof_field() quickly so
>> they don't gain more users, and the remaining FIELD_SIZEOF() users can be
>> whittled away as the patches come through the maintainer trees.
> 
> In that case I'd say let's live with FIELD_SIZEOF() and remove
> sizeof_field() and SIZEOF_FIELD().

The real question is whether we want to live with a sub-standard macro for
the next 20 years rather than taking the opportunity to clean it up now?

> I'm a bit surprised that the FIELD_SIZEOF() definition ends up in
> stddef.h rather than in kernel.h where such things are normally
> defined.  Why is that?

Cheers, Andreas






Download attachment "signature.asc" of type "application/pgp-signature" (874 bytes)

Powered by blists - more mailing lists