lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 19 Dec 2019 22:03:59 +0000
From:   Chaitanya Kulkarni <Chaitanya.Kulkarni@....com>
To:     Kirill Tkhai <ktkhai@...tuozzo.com>,
        "Martin K. Petersen" <martin.petersen@...cle.com>
CC:     "axboe@...nel.dk" <axboe@...nel.dk>,
        "linux-block@...r.kernel.org" <linux-block@...r.kernel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
        "linux-ext4@...r.kernel.org" <linux-ext4@...r.kernel.org>,
        "tytso@....edu" <tytso@....edu>,
        "adilger.kernel@...ger.ca" <adilger.kernel@...ger.ca>,
        "ming.lei@...hat.com" <ming.lei@...hat.com>,
        "osandov@...com" <osandov@...com>,
        "jthumshirn@...e.de" <jthumshirn@...e.de>,
        "minwoo.im.dev@...il.com" <minwoo.im.dev@...il.com>,
        Damien Le Moal <Damien.LeMoal@....com>,
        "andrea.parri@...rulasolutions.com" 
        <andrea.parri@...rulasolutions.com>,
        "hare@...e.com" <hare@...e.com>, "tj@...nel.org" <tj@...nel.org>,
        Ajay Joshi <Ajay.Joshi@....com>,
        "sagi@...mberg.me" <sagi@...mberg.me>,
        "dsterba@...e.com" <dsterba@...e.com>,
        "bvanassche@....org" <bvanassche@....org>,
        "dhowells@...hat.com" <dhowells@...hat.com>,
        "asml.silence@...il.com" <asml.silence@...il.com>
Subject: Re: [PATCH RFC 1/3] block: Add support for REQ_OP_ASSIGN_RANGE
 operation

> 1)Introduce a new flag BLKDEV_ZERO_ALLOCATE for blkdev_issue_write_zeroes().
> 2)Introduce a new flag REQ_NOZERO in enum req_opf.
>
> Won't this confuse a reader that we have blkdev_issue_write_zeroes(),
> which does not write zeroes sometimes? Maybe we should rename
> blkdev_issue_write_zeroes() in some more generic name?

Yes it will be confusing, I can see that the code for 
__blkdev_issue_write_zeroes() & __blkdev_issue_assign_range()
is very similar except op = REQ_OP_WRITE_ZEROES and
op = REQ_OP_ASSIGN_RANGE (and some minor details).

What we need is a prep patch which moves the payload less bio
code into the helper function which can accept op as an argument
based on that it will branch out and execute right code path.

If we decide to get this in then I'll be happy to create required
prep patch.
>
> Thanks,
> Kirill
>
>

Powered by blists - more mailing lists